summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-07 03:11:26 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-07 03:11:26 +0000
commit04ab1e25d51332964f71d567781e5bf97a78dbfc (patch)
tree82515bd7c9894dac70d4cbb6bb74ec6af77eccf4 /dev-util/glade
parentVersion bump. Assign Pinkbyte as maintainer. (diff)
downloadgentoo-2-04ab1e25d51332964f71d567781e5bf97a78dbfc.tar.gz
gentoo-2-04ab1e25d51332964f71d567781e5bf97a78dbfc.tar.bz2
gentoo-2-04ab1e25d51332964f71d567781e5bf97a78dbfc.zip
Version bump, adds inline margin/alignment editing and support for some additional widgets. Improve documentation slotting.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/ChangeLog9
-rw-r--r--dev-util/glade/files/glade-3.12.1-doc-version.patch46
-rw-r--r--dev-util/glade/glade-3.12.1.ebuild65
3 files changed, 119 insertions, 1 deletions
diff --git a/dev-util/glade/ChangeLog b/dev-util/glade/ChangeLog
index ada95f3d0598..a8adf74030ea 100644
--- a/dev-util/glade/ChangeLog
+++ b/dev-util/glade/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/glade
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.159 2012/05/04 17:51:44 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.160 2012/05/07 03:11:26 tetromino Exp $
+
+*glade-3.12.1 (07 May 2012)
+
+ 07 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +glade-3.12.1.ebuild, +files/glade-3.12.1-doc-version.patch:
+ Version bump, adds inline margin/alignment editing and support for some
+ additional widgets. Improve documentation slotting.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> glade-2.12.2-r1.ebuild,
glade-3.8.1.ebuild, glade-3.8.2.ebuild, glade-3.10.2.ebuild:
diff --git a/dev-util/glade/files/glade-3.12.1-doc-version.patch b/dev-util/glade/files/glade-3.12.1-doc-version.patch
new file mode 100644
index 000000000000..60842e7624cd
--- /dev/null
+++ b/dev-util/glade/files/glade-3.12.1-doc-version.patch
@@ -0,0 +1,46 @@
+From e3e91245e730f0532e913fde910054f464085241 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 6 May 2012 22:40:47 -0400
+Subject: [PATCH] Version glade documentation
+
+Rename gnome help files to prevent collision with other versions.
+
+Avoid loading glade-3.8's devhelp files.
+---
+ help/Makefile.am | 5 ++++-
+ src/glade-window.c | 2 +-
+ 2 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/help/Makefile.am b/help/Makefile.am
+index 70836e3..dd769c3 100644
+--- a/help/Makefile.am
++++ b/help/Makefile.am
+@@ -2,8 +2,11 @@
+ include $(top_srcdir)/gnome-doc-utils.make
+ dist-hook: doc-dist-hook
+
+-DOC_MODULE = glade
++DOC_MODULE = glade-@GLADE_MAJOR_VERSION@.@GLADE_MINOR_VERSION@
+ DOC_INCLUDES = legal.xml
+ DOC_FIGURES = figures/main-window.png
+
+ DOC_LINGUAS = bg ca cs de el en_GB es eu fr gl hi it ja oc pt_BR ru sl sv uk zh_CN
++
++C/$(DOC_MODULE).xml: $(top_srcdir)/help/C/glade.xml
++ cp -p $(top_srcdir)/help/C/glade.xml C/$(DOC_MODULE).xml
+diff --git a/src/glade-window.c b/src/glade-window.c
+index 89a4549..4eb8be5 100644
+--- a/src/glade-window.c
++++ b/src/glade-window.c
+@@ -2041,7 +2041,7 @@ show_developer_manual_cb (GtkAction * action, GladeWindow * window)
+ {
+ if (glade_util_have_devhelp ())
+ {
+- glade_util_search_devhelp ("gladeui", NULL, NULL);
++ glade_util_search_devhelp ("gladeui-2", NULL, NULL);
+ return;
+ }
+
+--
+1.7.8.6
+
diff --git a/dev-util/glade/glade-3.12.1.ebuild b/dev-util/glade/glade-3.12.1.ebuild
new file mode 100644
index 000000000000..34110316275a
--- /dev/null
+++ b/dev-util/glade/glade-3.12.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-3.12.1.ebuild,v 1.1 2012/05/07 03:11:26 tetromino Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome2 versionator
+
+DESCRIPTION="GNOME GUI Builder"
+HOMEPAGE="http://glade.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="3.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +introspection python"
+
+RDEPEND="dev-libs/atk[introspection?]
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2.4.0:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.4:3[introspection?]
+ x11-libs/pango[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.10.1 )
+ python? ( >=dev-python/pygobject-2.90.4:3 )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/gnome-doc-utils-0.18
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.41.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.13 )
+"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-libtool-lock
+ --disable-scrollkeeper
+ $(use_enable introspection)
+ $(use_enable python)"
+}
+
+src_prepare() {
+ # To avoid file collison with other slots, rename help module.
+ # Prevent the UI from loading glade:3's gladeui devhelp documentation.
+ epatch "${FILESDIR}/${P}-doc-version.patch"
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_install() {
+ # modify Name in .desktop file to avoid confusion with other slots
+ sed -e 's:^\(Name.*=Glade\):\1 '$(get_version_component_range 1-2): \
+ -i data/glade.desktop || die "sed of data/glade.desktop failed"
+ # modify name in .devhelp2 file to avoid shadowing with glade:3 docs
+ sed -e 's:name="gladeui":name="gladeui-2":' \
+ -i doc/html/gladeui.devhelp2 || die "sed of gladeui.devhelp2 failed"
+ gnome2_src_install
+}