summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-02-18 08:32:53 +0000
committerNaohiro Aota <naota@gentoo.org>2013-02-18 08:32:53 +0000
commit8d9b832aaf2ff00f51d8e15897f9aef2362069d2 (patch)
tree5bea72574b2270d21739062ddfc6b2a8f7939fa4 /dev-util/global
parentFixing init script to ensure /run directory exists, fixing #448464 (diff)
downloadgentoo-2-8d9b832aaf2ff00f51d8e15897f9aef2362069d2.tar.gz
gentoo-2-8d9b832aaf2ff00f51d8e15897f9aef2362069d2.tar.bz2
gentoo-2-8d9b832aaf2ff00f51d8e15897f9aef2362069d2.zip
Do not drop all .la files. #457856
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'dev-util/global')
-rw-r--r--dev-util/global/ChangeLog7
-rw-r--r--dev-util/global/global-6.2.7-r1.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index 2d4de21450d0..18a1edc0406a 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/global
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.105 2013/01/20 19:00:22 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.106 2013/02/18 08:32:53 naota Exp $
+
+*global-6.2.7-r1 (18 Feb 2013)
+
+ 18 Feb 2013; Naohiro Aota +global-6.2.7-r1.ebuild:
+ Do not drop all .la files. #457856
*global-6.2.7 (20 Jan 2013)
diff --git a/dev-util/global/global-6.2.7-r1.ebuild b/dev-util/global/global-6.2.7-r1.ebuild
new file mode 100644
index 000000000000..9f974811234e
--- /dev/null
+++ b/dev-util/global/global-6.2.7-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-6.2.7-r1.ebuild,v 1.1 2013/02/18 08:32:53 naota Exp $
+
+EAPI="5"
+
+inherit elisp-common eutils
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in various sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc emacs vim"
+
+RDEPEND="emacs? ( virtual/emacs )
+ vim? ( || ( app-editors/vim app-editors/gvim ) )"
+DEPEND="${DEPEND}
+ doc? ( app-text/texi2html sys-apps/texinfo )"
+
+SITEFILE="50gtags-gentoo.el"
+
+src_configure() {
+ econf "$(use_with emacs lispdir "${SITELISP}/${PN}")"
+}
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dohtml doc/global.html
+ [[ -f doc/global.pdf ]] && dodoc doc/global.pdf
+ fi
+
+ dodoc AUTHORS FAQ NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} *.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
+ fi
+
+ # Need to preserve some .la files to use plugin #457856
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}