summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-18 00:02:41 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-18 00:02:41 +0000
commitd2bcb703cbb1cd50b183e6f79621cbfa37cb1868 (patch)
tree4a520c44bc302e46407f79a279353dd70bb3ea2f /dev-util/gquilt
parent- stable on x86 and remove old ebuilds (diff)
downloadgentoo-2-d2bcb703cbb1cd50b183e6f79621cbfa37cb1868.tar.gz
gentoo-2-d2bcb703cbb1cd50b183e6f79621cbfa37cb1868.tar.bz2
gentoo-2-d2bcb703cbb1cd50b183e6f79621cbfa37cb1868.zip
fix python eclass use, bug #207667
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/gquilt')
-rw-r--r--dev-util/gquilt/ChangeLog7
-rw-r--r--dev-util/gquilt/gquilt-0.20.ebuild29
2 files changed, 31 insertions, 5 deletions
diff --git a/dev-util/gquilt/ChangeLog b/dev-util/gquilt/ChangeLog
index bb9d05a763c9..9aabda0838e7 100644
--- a/dev-util/gquilt/ChangeLog
+++ b/dev-util/gquilt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/gquilt
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gquilt/ChangeLog,v 1.13 2007/04/05 06:14:20 nerdboy Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gquilt/ChangeLog,v 1.14 2008/02/18 00:02:41 eva Exp $
+
+ 17 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org> gquilt-0.20.ebuild:
+ fix python eclass use, bug #207667
*gquilt-0.19 (05 Apr 2007)
*gquilt-0.18 (05 Apr 2007)
diff --git a/dev-util/gquilt/gquilt-0.20.ebuild b/dev-util/gquilt/gquilt-0.20.ebuild
index 49d4040a8c95..64b0770b5ec4 100644
--- a/dev-util/gquilt/gquilt-0.20.ebuild
+++ b/dev-util/gquilt/gquilt-0.20.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gquilt/gquilt-0.20.ebuild,v 1.1 2007/04/05 06:14:20 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gquilt/gquilt-0.20.ebuild,v 1.2 2008/02/18 00:02:41 eva Exp $
+
+inherit python
DESCRIPTION="A Python/GTK wrapper for quilt"
HOMEPAGE="http://users.bigpond.net.au/Peter-Williams/"
@@ -14,7 +16,28 @@ IUSE=""
RDEPEND="dev-util/quilt
>=dev-python/pygtk-2"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i "s/MODULES_BIN=.*/MODULES_BIN=/;
+ s/MODULES_OPT=.*/MODULES_OPT=/" Makefile
+ sed -i -e '/install -m 0644 $(MODULES_OPT)/s/\t/&#/g' Makefile
+ sed -i -e '/install -m 0644 $(MODULES_BIN)/s/\t/&#/g' Makefile
+}
+
src_install() {
- make DESTDIR="${D}" PREFIX="/usr" install || die "make install failed"
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "make install failed"
dodoc ChangeLog
}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/share/gquilt
+}
+
+
+pkg_prerm() {
+ python_version
+ python_mod_cleanup /usr/share/gquilt
+}