summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-06 12:47:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-06 12:47:47 +0000
commitb6c9ef4b788a25d3429e7d6a047ddee265429b48 (patch)
tree944751b76a1e63ef70182808c7795b99a6a5ee82 /dev-util/huc
parentstable amd64, bug 239729 (diff)
downloadgentoo-2-b6c9ef4b788a25d3429e7d6a047ddee265429b48.tar.gz
gentoo-2-b6c9ef4b788a25d3429e7d6a047ddee265429b48.tar.bz2
gentoo-2-b6c9ef4b788a25d3429e7d6a047ddee265429b48.zip
Ignore the makefile and build manually, respects LDFLAGS and does not strip the file. Remove COPYING file. Die if the dobin fails.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'dev-util/huc')
-rw-r--r--dev-util/huc/ChangeLog8
-rw-r--r--dev-util/huc/huc-0.1.ebuild25
2 files changed, 22 insertions, 11 deletions
diff --git a/dev-util/huc/ChangeLog b/dev-util/huc/ChangeLog
index f21c55abdcf4..e09ad2151a61 100644
--- a/dev-util/huc/ChangeLog
+++ b/dev-util/huc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/huc
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/huc/ChangeLog,v 1.11 2007/05/15 09:10:31 bangert Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/huc/ChangeLog,v 1.12 2008/10/06 12:47:47 flameeyes Exp $
+
+ 06 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> huc-0.1.ebuild:
+ Ignore the makefile and build manually, respects LDFLAGS and does not
+ strip the file. Remove COPYING file. Die if the dobin fails.
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/dev-util/huc/huc-0.1.ebuild b/dev-util/huc/huc-0.1.ebuild
index 9b6c6f81544e..ae37d9e2f518 100644
--- a/dev-util/huc/huc-0.1.ebuild
+++ b/dev-util/huc/huc-0.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/huc/huc-0.1.ebuild,v 1.15 2005/08/07 12:54:25 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/huc/huc-0.1.ebuild,v 1.16 2008/10/06 12:47:47 flameeyes Exp $
+
+inherit toolchain-funcs
DESCRIPTION="HTML umlaut conversion tool"
SRC_URI="http://www.int21.de/huc/${P}.tar.bz2"
@@ -13,13 +15,18 @@ IUSE=""
DEPEND="virtual/libc"
-src_compile()
-{
- emake CFLAGS="${CFLAGS}" || die
+doecho() {
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ doecho $(tc-getCXX) \
+ ${LDFLAGS} ${CXXFLAGS} \
+ -o ${PN} ${PN}.cpp || die "compile failed"
}
-src_install ()
-{
- dobin huc
- dodoc README COPYING
+src_install () {
+ dobin huc || die "dobin failed"
+ dodoc README
}