summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-03-04 04:57:44 +0000
committerJeroen Roovers <jer@gentoo.org>2010-03-04 04:57:44 +0000
commit707e5ada1effb53a4ceb05d20853af6a3b2d7215 (patch)
treec293c71c8d173ccf4aa92857b4f205c566ea13aa /dev-util/indent
parentStable for HPPA (bug #306667). (diff)
downloadgentoo-2-707e5ada1effb53a4ceb05d20853af6a3b2d7215.tar.gz
gentoo-2-707e5ada1effb53a4ceb05d20853af6a3b2d7215.tar.bz2
gentoo-2-707e5ada1effb53a4ceb05d20853af6a3b2d7215.zip
Remove old.
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'dev-util/indent')
-rw-r--r--dev-util/indent/ChangeLog8
-rw-r--r--dev-util/indent/files/2.2.9-deb-gentoo.patch112
-rw-r--r--dev-util/indent/files/2.2.9-indent-off-segfault.patch59
-rw-r--r--dev-util/indent/files/2.2.9-malloc.patch10
-rw-r--r--dev-util/indent/indent-2.2.10.ebuild38
-rw-r--r--dev-util/indent/indent-2.2.9-r3.ebuild40
-rw-r--r--dev-util/indent/indent-2.2.9-r4.ebuild43
7 files changed, 7 insertions, 303 deletions
diff --git a/dev-util/indent/ChangeLog b/dev-util/indent/ChangeLog
index 751909b72a40..fc74fb040a7a 100644
--- a/dev-util/indent/ChangeLog
+++ b/dev-util/indent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/indent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/ChangeLog,v 1.45 2010/02/13 16:23:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/ChangeLog,v 1.46 2010/03/04 04:57:43 jer Exp $
+
+ 04 Mar 2010; Jeroen Roovers <jer@gentoo.org>
+ -files/2.2.9-deb-gentoo.patch, -indent-2.2.9-r3.ebuild,
+ -files/2.2.9-indent-off-segfault.patch, -indent-2.2.9-r4.ebuild,
+ -files/2.2.9-malloc.patch, -indent-2.2.10.ebuild:
+ Remove old.
13 Feb 2010; Raúl Porcel <armin76@gentoo.org> indent-2.2.10-r1.ebuild:
alpha/arm/ia64/s390/sh stable wrt #302346
diff --git a/dev-util/indent/files/2.2.9-deb-gentoo.patch b/dev-util/indent/files/2.2.9-deb-gentoo.patch
deleted file mode 100644
index d560fa9a1157..000000000000
--- a/dev-util/indent/files/2.2.9-deb-gentoo.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-This patch is mostly from the debian indent_2.2.9-6.diff.
-
-Also added a patch to check usage of `texinfo2man`.
-http://bugs.gentoo.org/show_bug.cgi?id=71690
-
---- indent-2.2.9.orig/man/texinfo2man.c
-+++ indent-2.2.9/man/texinfo2man.c
-@@ -2,6 +2,7 @@
- #include <malloc.h>
- #include <string.h>
- #include <ctype.h>
-+#include <stdlib.h>
-
- /* texinfo2man.
- * Convert a texinfo document to man format.
-@@ -162,7 +163,7 @@
-
- static char value_updated[64], value_edition[64], value_version[64];
-
--process_texi (FILE * in)
-+void process_texi (FILE * in)
- {
- char buf[1024];
- int in_block = 0;
-@@ -252,6 +254,12 @@
- char buf[1024];
- int line_no = 0;
-
-+ if (argc != 3) {
-+ fprintf(stderr, "Usage: %s <man template> <info file>\n", argv[0]);
-+ fprintf(stderr, " The man page will be written to stdout.\n");
-+ return -1;
-+ }
-+
- texinfoname = argv[2];
-
- in = fopen (argv[2], "r");
---- indent-2.2.9.orig/src/output.c
-+++ indent-2.2.9/src/output.c
-@@ -13,8 +13,10 @@
-
- #include <stdio.h>
- #include <sys/types.h>
-+#include <time.h>
- #include <utime.h>
- #include <sys/stat.h>
-+#include <stdlib.h>
-
- #include "indent.h"
- #include "sys.h"
-@@ -1206,7 +1208,7 @@
- }
- }
-
--extern inhibit_indenting(
-+extern void inhibit_indenting(
- BOOLEAN flag)
- {
- inhibited = flag;
---- indent-2.2.9.orig/src/indent.h
-+++ indent-2.2.9/src/indent.h
-@@ -96,8 +96,6 @@
- /* Size of the input program, not including the ' \n\0' we add at the end */
- extern unsigned long in_prog_size;
-
--/* The output file. */
--extern FILE *output;
-
-
-
---- indent-2.2.9.orig/src/indent.c
-+++ indent-2.2.9/src/indent.c
-@@ -875,6 +875,7 @@
- * imply we are in a stmt */
- for (t_ptr = s_code; *t_ptr; ++t_ptr)
- {
-+ check_lab_size();
- *e_lab++ = *t_ptr; /* turn everything so far into a label */
- }
-
-@@ -3062,8 +3063,8 @@
- BOOLEAN using_stdin = false;
- exit_values_ty exit_status;
-
--#if defined (HAVE_SETLOCALE) && defined (HAVE_LC_MESSAGES)
-- setlocale (LC_MESSAGES, "");
-+#if defined (HAVE_SETLOCALE)
-+ setlocale (LC_ALL, "");
- #endif
- bindtextdomain (PACKAGE, LOCALEDIR);
- textdomain (PACKAGE);
---- indent-2.2.9.orig/src/comments.c
-+++ indent-2.2.9/src/comments.c
-@@ -20,6 +20,7 @@
- #include "comments.h"
- #include "globs.h"
- #include "parse.h"
-+#include "output.h"
-
- RCSTAG_CC ("$Id: 2.2.9-deb-gentoo.patch,v 1.2 2005/01/04 08:23:53 vapier Exp $");
-
---- indent-2.2.9.orig/src/output.h
-+++ indent-2.2.9/src/output.h
-@@ -47,7 +47,7 @@
- struct stat * file_stats,
- const char * filename);
-
--extern inhibit_indenting(
-+extern void inhibit_indenting(
- BOOLEAN flag);
-
-
diff --git a/dev-util/indent/files/2.2.9-indent-off-segfault.patch b/dev-util/indent/files/2.2.9-indent-off-segfault.patch
deleted file mode 100644
index 66ada66192a7..000000000000
--- a/dev-util/indent/files/2.2.9-indent-off-segfault.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff -ur indent-2.2.9.orig/src/indent.c indent-2.2.9/src/indent.c
---- indent-2.2.9.orig/src/indent.c 2002-10-28 12:00:56.000000000 -0800
-+++ indent-2.2.9/src/indent.c 2006-08-01 16:13:42.000000000 -0700
-@@ -103,6 +103,7 @@
- unsigned long in_prog_size = 0U;
- char * in_prog = NULL;
- int break_line = 0;
-+BOOLEAN inhibited = 0; /* Whether or not reformatting is currently disabled */
-
- /* The position that we will line the current line up with when it comes time
- * to print it (if we are lining up to parentheses). */
-@@ -2036,12 +2038,24 @@
- BOOLEAN * force_nl,
- BOOLEAN * flushed_nl)
- {
-+ BOOLEAN save_inhibited;
-+
- if (parser_state_tos->last_saw_nl && (s_code != e_code))
- {
-+ /* remember if this comment is actually *INDENT-OFF* directive */
-+ save_inhibited = inhibited;
-+
- *flushed_nl = false;
- dump_line(true, &paren_target);
- parser_state_tos->want_blank = false;
- *force_nl = false;
-+
-+ /* if the comment was *INDENT-OFF* directive, it has been used up already
-+ * by dump_line() above so return now */
-+ if (save_inhibited)
-+ {
-+ return;
-+ }
- }
- print_comment (&paren_target);
- }
-diff -ur indent-2.2.9.orig/src/indent.h indent-2.2.9/src/indent.h
---- indent-2.2.9.orig/src/indent.h 2002-11-10 13:02:48.000000000 -0800
-+++ indent-2.2.9/src/indent.h 2006-08-01 16:13:37.000000000 -0700
-@@ -124,6 +122,8 @@
-
- extern int break_line; /* Whether or not we should break the line. */
-
-+extern BOOLEAN inhibited; /* Whether or not reformatting is currently disabled */
-+
- /* pointer to the token that lexi() has just found */
- extern char *token;
-
-diff -ur indent-2.2.9.orig/src/output.c indent-2.2.9/src/output.c
---- indent-2.2.9.orig/src/output.c 2002-12-12 09:36:49.000000000 -0800
-+++ indent-2.2.9/src/output.c 2006-08-01 16:13:34.000000000 -0700
-@@ -24,7 +26,6 @@
- RCSTAG_CC ("$Id: 2.2.9-indent-off-segfault.patch,v 1.1 2006/07/31 06:10:31 wormo Exp $");
-
- static FILE * output = NULL;
--static BOOLEAN inhibited = 0;
- static buf_break_st_ty * buf_break_list = NULL;
-
- /* Priority mask bits */
diff --git a/dev-util/indent/files/2.2.9-malloc.patch b/dev-util/indent/files/2.2.9-malloc.patch
deleted file mode 100644
index 6dfcee76dc4c..000000000000
--- a/dev-util/indent/files/2.2.9-malloc.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -ur indent-2.2.9/man/texinfo2man.c indent-2.2.9-freebsd/man/texinfo2man.c
---- indent-2.2.9/man/texinfo2man.c 2002-01-17 20:28:51.000000000 +0100
-+++ indent-2.2.9-freebsd/man/texinfo2man.c 2005-07-30 11:13:26.616498832 +0200
-@@ -1,5 +1,5 @@
- #include <stdio.h>
--#include <malloc.h>
-+#include <stdlib.h>
- #include <string.h>
- #include <ctype.h>
-
diff --git a/dev-util/indent/indent-2.2.10.ebuild b/dev-util/indent/indent-2.2.10.ebuild
deleted file mode 100644
index 1a8ce3c5ed31..000000000000
--- a/dev-util/indent/indent-2.2.10.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/indent-2.2.10.ebuild,v 1.2 2009/11/23 03:46:41 jer Exp $
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="Indent program source files"
-HOMEPAGE="http://www.gnu.org/software/indent/indent.html"
-SRC_URI="mirror://gnu/indent/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls"
-
-DEPEND="nls? ( sys-devel/gettext )"
-RDEPEND="nls? ( virtual/libintl )"
-
-src_prepare() {
- # Update timestamp so it isn't regenerated #76610
- touch -r man/Makefile.am man/texinfo2man.c
-}
-
-src_configure() {
- # LINGUAS is used in aclocal.m4 #94837
- unset LINGUAS
- econf $(use_enable nls) || die
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- htmldir="/usr/share/doc/${PF}/html" \
- install || die "make install failed"
- dodoc AUTHORS NEWS README*
-}
diff --git a/dev-util/indent/indent-2.2.9-r3.ebuild b/dev-util/indent/indent-2.2.9-r3.ebuild
deleted file mode 100644
index 9577460ed27b..000000000000
--- a/dev-util/indent/indent-2.2.9-r3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/indent-2.2.9-r3.ebuild,v 1.12 2007/08/06 19:39:16 uberlord Exp $
-
-inherit eutils
-
-DESCRIPTION="Indent program source files"
-HOMEPAGE="http://www.gnu.org/software/indent/indent.html"
-SRC_URI="mirror://gnu/indent/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls"
-
-DEPEND="nls? ( sys-devel/gettext )"
-RDEPEND="nls? ( virtual/libintl )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-deb-gentoo.patch
- epatch "${FILESDIR}"/${PV}-malloc.patch
- epatch "${FILESDIR}"/${PV}-indent-off-segfault.patch # #125648
-
- # Update timestamp so it isn't regenerated #76610
- touch -r man/Makefile.am man/texinfo2man.c
-}
-
-src_compile() {
- econf $(use_enable nls) || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS NEWS README*
- dohtml "${D}"/usr/doc/indent/*
- rm -r "${D}"/usr/doc
-}
diff --git a/dev-util/indent/indent-2.2.9-r4.ebuild b/dev-util/indent/indent-2.2.9-r4.ebuild
deleted file mode 100644
index ff1f8dde2515..000000000000
--- a/dev-util/indent/indent-2.2.9-r4.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/indent-2.2.9-r4.ebuild,v 1.2 2007/08/06 19:39:16 uberlord Exp $
-
-inherit eutils
-
-DESCRIPTION="Indent program source files"
-HOMEPAGE="http://www.gnu.org/software/indent/indent.html"
-SRC_URI="mirror://gnu/indent/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls"
-
-DEPEND="nls? ( sys-devel/gettext )"
-RDEPEND="nls? ( virtual/libintl )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-deb-gentoo.patch
- epatch "${FILESDIR}"/${PV}-malloc.patch
- epatch "${FILESDIR}"/${PV}-indent-off-segfault.patch # #125648
-
- # Update timestamp so it isn't regenerated #76610
- touch -r man/Makefile.am man/texinfo2man.c
-}
-
-src_compile() {
- # LINGUAS is used in aclocal.m4 #94837
- unset LINGUAS
- econf $(use_enable nls) || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- htmldir="/usr/share/doc/${PF}/html" \
- install || die "make install failed"
- dodoc AUTHORS NEWS README*
-}