summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-03-03 18:19:07 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-03-03 18:19:07 +0000
commitc8a267d0d2d79d8ce63e6a3a9a88bbca486b7c8c (patch)
treedc031f359e7123533fe1762ffc37b2eddd4567e0 /dev-util/insight
parentThe ebuild submitted by Leknor@Leknor.com (William A. McArthur, Jr.), (diff)
downloadgentoo-2-c8a267d0d2d79d8ce63e6a3a9a88bbca486b7c8c.tar.gz
gentoo-2-c8a267d0d2d79d8ce63e6a3a9a88bbca486b7c8c.tar.bz2
gentoo-2-c8a267d0d2d79d8ce63e6a3a9a88bbca486b7c8c.zip
Insight is a tcl/tk frontend to gdb. This package installs its own
versions of Tk, Tcl, gdb, etc. (ouch!), with no apparent option to use system-wide copies of the libraries. Hence stuffed it into /opt/insight. The ebuild is based on the one, submitted by marc@aspre.net (Marc Soda). Closes bug 714.
Diffstat (limited to 'dev-util/insight')
-rw-r--r--dev-util/insight/ChangeLog14
-rw-r--r--dev-util/insight/files/99insight3
-rw-r--r--dev-util/insight/files/digest-insight-5.1.11
-rw-r--r--dev-util/insight/insight-5.1.1.ebuild37
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/insight/ChangeLog b/dev-util/insight/ChangeLog
new file mode 100644
index 000000000000..63a307e8bd34
--- /dev/null
+++ b/dev-util/insight/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for dev-utils/insight
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/ChangeLog,v 1.1 2002/03/03 18:19:07 agenkin Exp $
+
+*insight-5.1.1; (15 Feb 2002)
+
+ 3 Mar 2002; Arcady Genkin <agenkin@thpoon.com> insight-5.1.1.ebuild :
+
+ Modified to put everything into /opt/insight.
+ Added insight entry to /etc/env.d.
+
+ 15 Feb 2002; Marc Soda <marc@aspre.net> insight-5.1.1.ebuild :
+
+ Initial version.
diff --git a/dev-util/insight/files/99insight b/dev-util/insight/files/99insight
new file mode 100644
index 000000000000..07f191fa5b0b
--- /dev/null
+++ b/dev-util/insight/files/99insight
@@ -0,0 +1,3 @@
+PATH=/opt/insight/bin
+LDPATH=/opt/insight/lib
+MANPATH=/opt/insight/man \ No newline at end of file
diff --git a/dev-util/insight/files/digest-insight-5.1.1 b/dev-util/insight/files/digest-insight-5.1.1
new file mode 100644
index 000000000000..5e4b85629564
--- /dev/null
+++ b/dev-util/insight/files/digest-insight-5.1.1
@@ -0,0 +1 @@
+MD5 832570caf2a83d2805f9d4bf033993f0 insight-5.1.1.tar.bz2 15883037
diff --git a/dev-util/insight/insight-5.1.1.ebuild b/dev-util/insight/insight-5.1.1.ebuild
new file mode 100644
index 000000000000..3480f3862f30
--- /dev/null
+++ b/dev-util/insight/insight-5.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Marc Soda <marc@aspre.net>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-5.1.1.ebuild,v 1.1 2002/03/03 18:19:07 agenkin Exp $
+
+DESCRIPTION="A graphical interface to the GNU debugger"
+HOMEPAGE="http://sources.redhat.com/insight/index.html"
+
+SRC_URI="ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2"
+S="${WORKDIR}/${P}"
+
+DEPEND="virtual/glibc
+ sys-libs/ncurses
+ nls? ( sys-devel/gettext )"
+
+INSIGHTDIR="/opt/insight"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]; then
+ myconf="--disable-nls"
+ fi
+ ./configure \
+ --host="${CHOST}" \
+ --prefix="${INSIGHTDIR}" \
+ --without-included-regex \
+ --without-included-gettext \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ make prefix="${D}${INSIGHTDIR}" install || die
+ dosym /opt/insight/bin/gdb /opt/insight/bin/insight
+ insinto /etc/env.d
+ doins "${FILESDIR}/99insight"
+}