summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-10-05 19:24:48 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-10-05 19:24:48 +0000
commitac2f89033a713de4462fc8ab459a0369e1d58a81 (patch)
tree75bab6bb07659a6933071efd566e3aa54313de86 /dev-util/kbuild
parentswapped snprintf for sprintf to support arm's broken C++98 (bug 430502) (diff)
downloadgentoo-2-ac2f89033a713de4462fc8ab459a0369e1d58a81.tar.gz
gentoo-2-ac2f89033a713de4462fc8ab459a0369e1d58a81.tar.bz2
gentoo-2-ac2f89033a713de4462fc8ab459a0369e1d58a81.zip
Respect CC,AR,RANLIB, wrt to bug #380063
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/kbuild')
-rw-r--r--dev-util/kbuild/ChangeLog7
-rw-r--r--dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild11
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-util/kbuild/ChangeLog b/dev-util/kbuild/ChangeLog
index fb06358b20ac..cb0b041f5e6e 100644
--- a/dev-util/kbuild/ChangeLog
+++ b/dev-util/kbuild/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/kbuild
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kbuild/ChangeLog,v 1.30 2012/08/06 17:27:55 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kbuild/ChangeLog,v 1.31 2012/10/05 19:24:48 ago Exp $
+
+ 05 Oct 2012; Agostino Sarubbo <ago@gentoo.org>
+ kbuild-0.1.9998_pre20120806.ebuild:
+ Respect CC,AR,RANLIB, wrt to bug #380063
*kbuild-0.1.9998_pre20120806 (06 Aug 2012)
@@ -160,4 +164,3 @@
03 Sep 2008; Alessio Cassibba (X-Drum) <swapon@gmail.com>
+kbuild-0.1.3.ebuild, +metadata.xml:
Initial ebuild for kBuild
-
diff --git a/dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild b/dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild
index 7318c90be041..ace8bef085c8 100644
--- a/dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild
+++ b/dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild,v 1.1 2012/08/06 17:27:55 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kbuild/kbuild-0.1.9998_pre20120806.ebuild,v 1.2 2012/10/05 19:24:48 ago Exp $
EAPI=4
WANT_AUTOMAKE=1.9
-inherit eutils autotools
+inherit eutils autotools toolchain-funcs
MY_P=kBuild-${PV/_/-}-src
DESCRIPTION="A makefile framework for writing simple makefiles for complex tasks"
@@ -37,17 +37,18 @@ src_prepare() {
"${FILESDIR}/${PN}-0.1.9998_pre20110817-gold.patch" \
"${FILESDIR}/${PN}-0.1.9998_pre20110817-gcc-4.7.patch"
- cd "${S}/src/kmk"
+ cd "${S}/src/kmk" || die
eautoreconf
- cd "${S}/src/sed"
+ cd "${S}/src/sed" || die
eautoreconf
sed -e "s@_LDFLAGS\.${ARCH}*.*=@& ${LDFLAGS}@g" \
-i "${S}"/Config.kmk || die #332225
+ tc-export CC RANLIB #AR does not work here
}
src_compile() {
- kBuild/env.sh --full make -f bootstrap.gmk AUTORECONF=true \
+ kBuild/env.sh --full make -f bootstrap.gmk AUTORECONF=true AR="$(tc-getAR)" \
|| die "bootstrap failed"
}