summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-12-01 13:01:34 +0000
committerTim Harder <radhermit@gentoo.org>2012-12-01 13:01:34 +0000
commit77b7a8141badddff5f2bdc7289e6cd94ec5fcd32 (patch)
tree98c320b383b77dde1bea7b5b916cfeeed900c408 /dev-util/ltrace
parentRm calls to die for EAPI4 (diff)
downloadgentoo-2-77b7a8141badddff5f2bdc7289e6cd94ec5fcd32.tar.gz
gentoo-2-77b7a8141badddff5f2bdc7289e6cd94ec5fcd32.tar.bz2
gentoo-2-77b7a8141badddff5f2bdc7289e6cd94ec5fcd32.zip
Revision bump. Add debug and unwind use flags. Use pkg-config to detect unwind libraries (fixes bug #445438).
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-util/ltrace')
-rw-r--r--dev-util/ltrace/ChangeLog9
-rw-r--r--dev-util/ltrace/files/ltrace-0.7.1-libunwind-pkgconfig.patch32
-rw-r--r--dev-util/ltrace/ltrace-0.7.1-r1.ebuild37
-rw-r--r--dev-util/ltrace/metadata.xml3
4 files changed, 80 insertions, 1 deletions
diff --git a/dev-util/ltrace/ChangeLog b/dev-util/ltrace/ChangeLog
index 093f90458c09..9ff0dd681abd 100644
--- a/dev-util/ltrace/ChangeLog
+++ b/dev-util/ltrace/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/ltrace
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ChangeLog,v 1.55 2012/11/30 22:58:33 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ChangeLog,v 1.56 2012/12/01 13:01:33 radhermit Exp $
+
+*ltrace-0.7.1-r1 (01 Dec 2012)
+
+ 01 Dec 2012; Tim Harder <radhermit@gentoo.org> +ltrace-0.7.1-r1.ebuild,
+ +files/ltrace-0.7.1-libunwind-pkgconfig.patch, metadata.xml:
+ Revision bump. Add debug and unwind use flags. Use pkg-config to detect
+ unwind libraries (fixes bug #445438).
*ltrace-0.7.1 (30 Nov 2012)
diff --git a/dev-util/ltrace/files/ltrace-0.7.1-libunwind-pkgconfig.patch b/dev-util/ltrace/files/ltrace-0.7.1-libunwind-pkgconfig.patch
new file mode 100644
index 000000000000..da63b171cbf8
--- /dev/null
+++ b/dev-util/ltrace/files/ltrace-0.7.1-libunwind-pkgconfig.patch
@@ -0,0 +1,32 @@
+--- ltrace-0.7.1/configure.ac
++++ ltrace-0.7.1/configure.ac
+@@ -154,26 +154,10 @@
+ AC_MSG_RESULT([$enable_libunwind])
+
+ if test x"$enable_libunwind" = xyes; then
+- saved_LDFLAGS="${LDFLAGS}"
+- LDFLAGS="${LDFLAGS} ${AM_LDFLAGS}"
+- AC_CHECK_LIB(unwind, backtrace, libunwind_LIBS=-lunwind, libunwind_LIBS=)
+- AC_SUBST(libunwind_LIBS)
+- AC_CHECK_LIB(unwind-ptrace, _UPT_create, libunwind_ptrace_LIBS=-lunwind-ptrace, libunwind_ptrace_LIBS=)
+- AC_SUBST(libunwind_ptrace_LIBS)
+-
+- case "${host_cpu}" in
+- arm*|sa110) UNWIND_ARCH="arm" ;;
+- i?86) UNWIND_ARCH="x86" ;;
+- powerpc) UNWIND_ARCH="ppc32" ;;
+- ppc64) UNWIND_ARCH="ppc64" ;;
+- mips*) UNWIND_ARCH="mips" ;;
+- *) UNWIND_ARCH="${host_cpu}" ;;
+- esac
+-
+- AC_CHECK_LIB(unwind-${UNWIND_ARCH}, _U${UNWIND_ARCH}_init_remote, libunwind_arch_LIBS=-lunwind-${UNWIND_ARCH}, libunwind_arch_LIBS=)
+- AC_SUBST(libunwind_arch_LIBS)
++ PKG_CHECK_MODULES([libunwind], [libunwind-generic])
++ PKG_CHECK_MODULES([libunwind_ptrace], [libunwind-ptrace])
++ PKG_CHECK_MODULES([libunwind_arch], [libunwind])
+ AC_DEFINE([HAVE_LIBUNWIND], [1], [we have libunwind])
+- LDFLAGS="${saved_LDFLAGS}"
+ fi
+
+
diff --git a/dev-util/ltrace/ltrace-0.7.1-r1.ebuild b/dev-util/ltrace/ltrace-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..e91b90c60e5e
--- /dev/null
+++ b/dev-util/ltrace/ltrace-0.7.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ltrace-0.7.1-r1.ebuild,v 1.1 2012/12/01 13:01:33 radhermit Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+NUM="3844"
+
+DESCRIPTION="trace library calls made at runtime"
+HOMEPAGE="http://ltrace.alioth.debian.org/"
+SRC_URI="https://alioth.debian.org/frs/download.php/${NUM}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="debug test unwind"
+
+RDEPEND="dev-libs/elfutils
+ unwind? ( sys-libs/libunwind )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/dejagnu )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libunwind-pkgconfig.patch
+ sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with unwind libunwind)
+}
diff --git a/dev-util/ltrace/metadata.xml b/dev-util/ltrace/metadata.xml
index 028d1cef3af8..dce9e2ed8fa4 100644
--- a/dev-util/ltrace/metadata.xml
+++ b/dev-util/ltrace/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>dev-tools</herd>
+ <use>
+ <flag name="unwind">Use <pkg>sys-libs/libunwind</pkg> for frame unwinding support</flag>
+ </use>
</pkgmetadata>