summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-08 18:10:57 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-08 18:10:57 +0000
commit8ab90046fa0f9c094b199b00449f5ba183f39657 (patch)
tree2cf510b74fcd63de4cd0ca8b7666051923c35f04 /dev-util/ninja-ide/ninja-ide-2.3.ebuild
parentVersion bump. (diff)
downloadgentoo-2-8ab90046fa0f9c094b199b00449f5ba183f39657.tar.gz
gentoo-2-8ab90046fa0f9c094b199b00449f5ba183f39657.tar.bz2
gentoo-2-8ab90046fa0f9c094b199b00449f5ba183f39657.zip
version bump wrt #476176
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-util/ninja-ide/ninja-ide-2.3.ebuild')
-rw-r--r--dev-util/ninja-ide/ninja-ide-2.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/ninja-ide/ninja-ide-2.3.ebuild b/dev-util/ninja-ide/ninja-ide-2.3.ebuild
new file mode 100644
index 000000000000..3db2e33b2b6a
--- /dev/null
+++ b/dev-util/ninja-ide/ninja-ide-2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja-ide/ninja-ide-2.3.ebuild,v 1.1 2013/07/08 18:10:57 hasufell Exp $
+
+# XXX: tests
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 python3_1 python3_2 python3_3 )
+
+inherit eutils gnome2-utils distutils-r1 vcs-snapshot
+
+DESCRIPTION="Ninja-IDE Is Not Just Another IDE"
+HOMEPAGE="http://www.ninja-ide.org"
+SRC_URI="https://github.com/ninja-ide/ninja-ide/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt4[X,declarative,webkit,${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ virtual/python-json[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-syntax.patch
+ "${FILESDIR}"/${P}-python2_6.patch
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newicon -s 256 icon.png ${PN}.png
+ make_desktop_entry ${PN} "NINJA-IDE"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}