summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-03-30 09:16:07 +0000
committerMichał Górny <mgorny@gentoo.org>2014-03-30 09:16:07 +0000
commit2d1552df6046efa5a48fb940e7c3e6e59869c8bc (patch)
tree5efa07c0dc7eaa35bee2ed7380c10dc3066cb486 /dev-util/pkgconf
parentDrop maintainer as talked with him (#398377) (diff)
downloadgentoo-2-2d1552df6046efa5a48fb940e7c3e6e59869c8bc.tar.gz
gentoo-2-2d1552df6046efa5a48fb940e7c3e6e59869c8bc.tar.bz2
gentoo-2-2d1552df6046efa5a48fb940e7c3e6e59869c8bc.zip
Enable multilib support, bug #506062.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/ChangeLog8
-rw-r--r--dev-util/pkgconf/pkgconf-0.9.3-r1.ebuild56
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild25
3 files changed, 81 insertions, 8 deletions
diff --git a/dev-util/pkgconf/ChangeLog b/dev-util/pkgconf/ChangeLog
index 9f523b610a52..b508c955b0da 100644
--- a/dev-util/pkgconf/ChangeLog
+++ b/dev-util/pkgconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pkgconf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.82 2014/02/13 19:20:29 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.83 2014/03/30 09:16:07 mgorny Exp $
+
+*pkgconf-0.9.3-r1 (30 Mar 2014)
+
+ 30 Mar 2014; Michał Górny <mgorny@gentoo.org> +pkgconf-0.9.3-r1.ebuild,
+ pkgconf-9999.ebuild:
+ Enable multilib support, bug #506062.
13 Feb 2014; Richard Yao <ryao@gentoo.org> pkgconf-0.9.3.ebuild:
keyword on ~x64-solaris
diff --git a/dev-util/pkgconf/pkgconf-0.9.3-r1.ebuild b/dev-util/pkgconf/pkgconf-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..0003b0bf2488
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-0.9.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.9.3-r1.ebuild,v 1.1 2014/03/30 09:16:07 mgorny Exp $
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
+ inherit autotools git-2 multilib-minimal
+else
+ inherit eutils multilib-minimal
+ SRC_URI="http://tortois.es/~nenolod/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/pkgconf/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf
+)
+
+src_prepare() {
+ [[ -e configure ]] || eautoreconf
+
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config
+ )
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf $(use_enable strict)
+}
+
+multilib_src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index b8dc762127c8..c8d57c60a959 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-9999.ebuild,v 1.12 2012/10/17 15:51:49 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-9999.ebuild,v 1.13 2014/03/30 09:16:07 mgorny Exp $
-EAPI="4"
+EAPI=5
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
- inherit autotools git-2
+ inherit autotools git-2 multilib-minimal
else
- inherit autotools vcs-snapshot
+ inherit autotools multilib-minimal vcs-snapshot
SRC_URI="https://github.com/pkgconf/pkgconf/tarball/${P} -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
fi
@@ -28,15 +28,26 @@ RDEPEND="${DEPEND}
!dev-util/pkgconfig-openbsd[pkg-config]
)"
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf
+)
+
src_prepare() {
[[ -e configure ]] || eautoreconf
+
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config
+ )
+ fi
}
-src_configure() {
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
econf $(use_enable strict)
}
-src_install() {
+multilib_src_install() {
default
use pkg-config \
&& dosym pkgconf /usr/bin/pkg-config \