summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-04 13:07:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-04 13:07:25 +0000
commit0f7e340d0c8ab2238c2195bfab036d0e9da20cc8 (patch)
treeee16116fb955610091d7128b9aa91227dee067f1 /dev-util/pkgconfig-openbsd
parentInclude dev-util/pkgconfig-openbsd[pkg-config]. (diff)
downloadgentoo-2-0f7e340d0c8ab2238c2195bfab036d0e9da20cc8.tar.gz
gentoo-2-0f7e340d0c8ab2238c2195bfab036d0e9da20cc8.tar.bz2
gentoo-2-0f7e340d0c8ab2238c2195bfab036d0e9da20cc8.zip
New snapshot with USE="pkg-config" for compability with virtual/pkgconfig.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/pkgconfig-openbsd')
-rw-r--r--dev-util/pkgconfig-openbsd/ChangeLog8
-rw-r--r--dev-util/pkgconfig-openbsd/metadata.xml3
-rw-r--r--dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120504.ebuild61
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-util/pkgconfig-openbsd/ChangeLog b/dev-util/pkgconfig-openbsd/ChangeLog
index cd0af2f312c5..85dc40f80439 100644
--- a/dev-util/pkgconfig-openbsd/ChangeLog
+++ b/dev-util/pkgconfig-openbsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pkgconfig-openbsd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/ChangeLog,v 1.3 2012/01/17 00:46:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/ChangeLog,v 1.4 2012/05/04 13:07:25 ssuominen Exp $
+
+*pkgconfig-openbsd-20120504 (04 May 2012)
+
+ 04 May 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +pkgconfig-openbsd-20120504.ebuild, metadata.xml:
+ New snapshot with USE="pkg-config" for compability with virtual/pkgconfig.
17 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
pkgconfig-openbsd-20120116.ebuild:
diff --git a/dev-util/pkgconfig-openbsd/metadata.xml b/dev-util/pkgconfig-openbsd/metadata.xml
index c2d865517c00..37d754051771 100644
--- a/dev-util/pkgconfig-openbsd/metadata.xml
+++ b/dev-util/pkgconfig-openbsd/metadata.xml
@@ -5,4 +5,7 @@
<email>ssuominen@gentoo.org</email>
<name>Samuli Suominen</name>
</maintainer>
+ <use>
+ <flag name='pkg-config'>Install as a replacement for <pkg>dev-util/pkgconfig</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120504.ebuild b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120504.ebuild
new file mode 100644
index 000000000000..ac148b87377f
--- /dev/null
+++ b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120504.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120504.ebuild,v 1.1 2012/05/04 13:07:25 ssuominen Exp $
+
+# cvs -d anoncvs@anoncvs.openbsd.org:/cvs get src/usr.bin/pkg-config/pkg-config
+# cvs -d anoncvs@anoncvs.openbsd.org:/cvs get src/usr.bin/pkg-config/pkg-config.1
+# cvs -d anoncvs@anoncvs.openbsd.org:/cvs get src/usr.sbin/pkg_add/OpenBSD/PkgConfig.pm
+
+EAPI=4
+
+PKG_M4_VERSION=0.26
+
+DESCRIPTION="A perl based version of pkg-config from OpenBSD"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/pkg-config/ http://www.openbsd.org/cgi-bin/cvsweb/src/usr.sbin/pkg_add/OpenBSD/PkgConfig.pm"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz
+ pkg-config? ( http://pkgconfig.freedesktop.org/releases/pkg-config-${PKG_M4_VERSION}.tar.gz )"
+
+LICENSE="ISC pkg-config? ( GPL-2 )"
+SLOT="0"
+KEYWORDS=""
+IUSE="pkg-config"
+
+DEPEND="
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconf[pkg-config]
+ )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+S=${WORKDIR}/src
+
+src_prepare() {
+ # Config.pm from dev-lang/perl doesn't set ARCH, only archname
+ sed -i -e '/Config/s:ARCH:archname:' usr.bin/pkg-config/pkg-config || die
+}
+
+src_install() {
+ if use pkg-config; then
+ dobin usr.bin/pkg-config/pkg-config
+ doman usr.bin/pkg-config/pkg-config.1
+
+ insinto /usr/share/aclocal
+ doins "${WORKDIR}"/pkg-config-*/pkg.m4
+ else
+ newbin usr.bin/pkg-config/pkg-config pkg-config-openbsd
+ newman usr.bin/pkg-config/pkg-config.1 pkg-config-openbsd.1
+ fi
+
+ insinto /usr/share/${PN}/OpenBSD
+ doins usr.sbin/pkg_add/OpenBSD/PkgConfig.pm
+
+ cat <<-EOF > "${T}"/99${PN}
+ COLON_SEPARATED=PERL5LIB
+ PERL5LIB=/usr/share/${PN}
+ EOF
+
+ doenvd "${T}"/99${PN}
+}