summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-22 23:41:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-22 23:41:01 +0000
commit2fddbad37f310ee5d697a8ea64fcf5b10ef48097 (patch)
tree892df8106d95677adc4bbbfbdd5daba1a7d2242c /dev-util/ragel/ragel-6.7-r1.ebuild
parentBump to prerelease. (diff)
downloadgentoo-2-2fddbad37f310ee5d697a8ea64fcf5b10ef48097.tar.gz
gentoo-2-2fddbad37f310ee5d697a8ea64fcf5b10ef48097.tar.bz2
gentoo-2-2fddbad37f310ee5d697a8ea64fcf5b10ef48097.zip
Add patch to build with GCC 4.7; respect CXXFLAGS correctly. Closes bugs #394927 and #412347.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/ragel/ragel-6.7-r1.ebuild')
-rw-r--r--dev-util/ragel/ragel-6.7-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/ragel/ragel-6.7-r1.ebuild b/dev-util/ragel/ragel-6.7-r1.ebuild
new file mode 100644
index 000000000000..8e6b07c00ba1
--- /dev/null
+++ b/dev-util/ragel/ragel-6.7-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ragel-6.7-r1.ebuild,v 1.1 2012/05/22 23:41:01 flameeyes Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="Compiles finite state machines from regular languages into executable code."
+HOMEPAGE="http://www.complang.org/ragel/"
+SRC_URI="http://www.complang.org/ragel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND=""
+
+# We need to get the txl language in Portage to have the tests :(
+RESTRICT=test
+
+DOCS=( ChangeLog CREDITS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}+gcc-4.7.patch
+ sed -i -e '/CXXFLAGS/d' configure.ac
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_test() {
+ cd "${S}"/test
+ ./runtests.in || die
+}
+
+src_install() {
+ default
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim || die "doins ragel.vim failed"
+ fi
+}