summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2013-03-03 16:57:25 +0000
committerWolfram Schlich <wschlich@gentoo.org>2013-03-03 16:57:25 +0000
commitfb4467b7f7f91e0cf564b5b2cb21dbd56952d52c (patch)
treeaefe0b643b37404f86900fb1fdd6c47ad654ce5d /dev-util/sel
parentUpdate homepage (#453728 by Peter Albrecht), drop old. (diff)
downloadgentoo-2-fb4467b7f7f91e0cf564b5b2cb21dbd56952d52c.tar.gz
gentoo-2-fb4467b7f7f91e0cf564b5b2cb21dbd56952d52c.tar.bz2
gentoo-2-fb4467b7f7f91e0cf564b5b2cb21dbd56952d52c.zip
fix bug #442150
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-util/sel')
-rw-r--r--dev-util/sel/ChangeLog9
-rw-r--r--dev-util/sel/sel-0.08.4-r1.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-util/sel/ChangeLog b/dev-util/sel/ChangeLog
index 7a0ffc810c5f..dd7f00145a75 100644
--- a/dev-util/sel/ChangeLog
+++ b/dev-util/sel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/sel
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/sel/ChangeLog,v 1.15 2012/10/29 07:16:32 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sel/ChangeLog,v 1.16 2013/03/03 16:57:25 wschlich Exp $
+
+*sel-0.08.4-r1 (03 Mar 2013)
+
+ 03 Mar 2013; Wolfram Schlich <wschlich@gentoo.org> +sel-0.08.4-r1.ebuild:
+ fix bug #442150
29 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> sel-0.08.4.ebuild:
Add missing 'die' statement to sed, keyword ~amd64 wrt bug #439868, thanks to
diff --git a/dev-util/sel/sel-0.08.4-r1.ebuild b/dev-util/sel/sel-0.08.4-r1.ebuild
new file mode 100644
index 000000000000..7601a36493af
--- /dev/null
+++ b/dev-util/sel/sel-0.08.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sel/sel-0.08.4-r1.ebuild,v 1.1 2013/03/03 16:57:25 wschlich Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="A filemanager for shell scripts"
+SRC_URI="http://www.rninet.de/darkstar/files/${P}.tar.gz"
+HOMEPAGE="http://www.rninet.de/darkstar/sel.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.1"
+DEPEND="${RDEPEND}"
+
+src_prepare () {
+ sed -i -e "s:/usr/local/share/sel/help\.txt:/usr/share/sel/help\.txt:" \
+ sel.c || die 'sed failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDLIBS="-lncurses"
+}
+
+src_install () {
+ dobin sel
+ doman sel.1
+ insinto /usr/share/sel
+ doins help.txt
+ dodoc README.GER
+}