summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-07-01 18:50:30 +0000
committerJeroen Roovers <jer@gentoo.org>2014-07-01 18:50:30 +0000
commitfac2d4dfe95c90ee304a783bc13bda640d4a858f (patch)
tree510ab848c5524d73296aea51914ca63e322466ae /dev-util/splint
parentFix bug#515814, cleanup (diff)
downloadgentoo-2-fac2d4dfe95c90ee304a783bc13bda640d4a858f.tar.gz
gentoo-2-fac2d4dfe95c90ee304a783bc13bda640d4a858f.tar.bz2
gentoo-2-fac2d4dfe95c90ee304a783bc13bda640d4a858f.zip
Fix some QA issues.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util/splint')
-rw-r--r--dev-util/splint/ChangeLog5
-rw-r--r--dev-util/splint/splint-3.1.2-r1.ebuild14
2 files changed, 17 insertions, 2 deletions
diff --git a/dev-util/splint/ChangeLog b/dev-util/splint/ChangeLog
index 4525739691a2..31f85f92beb8 100644
--- a/dev-util/splint/ChangeLog
+++ b/dev-util/splint/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/splint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/splint/ChangeLog,v 1.30 2014/06/18 13:43:06 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/splint/ChangeLog,v 1.31 2014/07/01 18:50:30 jer Exp $
+
+ 01 Jul 2014; Jeroen Roovers <jer@gentoo.org> splint-3.1.2-r1.ebuild:
+ Fix some QA issues.
18 Jun 2014; Tobias Klausmann <klausman@gentoo.org> splint-3.1.2-r1.ebuild:
Keyworded on alpha, bug #441688
diff --git a/dev-util/splint/splint-3.1.2-r1.ebuild b/dev-util/splint/splint-3.1.2-r1.ebuild
index d81bd03f7eb5..071ac9be2a18 100644
--- a/dev-util/splint/splint-3.1.2-r1.ebuild
+++ b/dev-util/splint/splint-3.1.2-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/splint/splint-3.1.2-r1.ebuild,v 1.2 2014/06/18 13:43:06 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/splint/splint-3.1.2-r1.ebuild,v 1.3 2014/07/01 18:50:30 jer Exp $
EAPI=5
+inherit autotools
DESCRIPTION="Check C programs for vulnerabilities and programming mistakes"
HOMEPAGE="http://lclint.cs.virginia.edu/"
@@ -16,6 +17,17 @@ DEPEND="
sys-devel/flex
"
+src_prepare() {
+ # verbose compiler calls
+ sed -i -e '/Compiling/d' src/Makefile.am || die
+ # automake complains about trailing \
+ sed -i -e '1600d' test/Makefile.am || die
+ # do not install these header files twice
+ sed -i -e '/\$(UnixHeaders)/s|stdio.h stdlib.h||g' lib/Makefile.am || die
+
+ eautoreconf
+}
+
src_configure() {
# We do not need bison/yacc at all here
# We definitely need libfl