summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-06-13 07:00:52 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-06-13 07:00:52 +0000
commit7112733ec500ccf385ef9683ca26112e1e322335 (patch)
tree471443dfb5dc90c666302c335c96ed407f0c8c61 /dev-util/strace/strace-4.4.98.ebuild
parentversion bump as per Bug 22718 (diff)
downloadgentoo-2-7112733ec500ccf385ef9683ca26112e1e322335.tar.gz
gentoo-2-7112733ec500ccf385ef9683ca26112e1e322335.tar.bz2
gentoo-2-7112733ec500ccf385ef9683ca26112e1e322335.zip
version bump as per Bug 22718
Diffstat (limited to 'dev-util/strace/strace-4.4.98.ebuild')
-rw-r--r--dev-util/strace/strace-4.4.98.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/strace/strace-4.4.98.ebuild b/dev-util/strace/strace-4.4.98.ebuild
new file mode 100644
index 000000000000..92e2f25e9482
--- /dev/null
+++ b/dev-util/strace/strace-4.4.98.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.4.98.ebuild,v 1.1 2003/06/13 07:00:48 msterret Exp $
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.wi.leidenuniv.nl/~wichert/strace/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips"
+inherit flag-o-matic
+
+DEPEND="virtual/glibc
+ >=sys-devel/autoconf-2.54"
+
+src_compile() {
+ # Compile fails with -O3 on sparc but works on x86
+ if [ "${ARCH}" == "sparc" -o "${ARCH}" == "" ]; then
+ replace-flags -O[3-9] -O2
+ fi
+ # configure is broken by default for sparc and possibly others, regen
+ # from configure.in
+ autoconf
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ # Can't use make install because it is stupid and
+ # doesn't make leading directories before trying to
+ # install. Thus, one would have to make /usr/bin
+ # and /usr/man/man1 (at least).
+ # So, we do it by hand.
+ doman strace.1
+ dobin strace
+ dobin strace-graph
+ dodoc ChangeLog COPYRIGHT CREDITS NEWS PORTING README* TODO
+}