summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-22 03:15:40 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-22 03:15:40 +0000
commitbe37737fc804f8fd40eb59527927d2fd609270c0 (patch)
treeb90220ecbf21d2b0377e54272fc029459afbb1f7 /dev-util/strace/strace-4.5.7.ebuild
parents390 updates #52609 (Manifest recommit) (diff)
downloadgentoo-2-be37737fc804f8fd40eb59527927d2fd609270c0.tar.gz
gentoo-2-be37737fc804f8fd40eb59527927d2fd609270c0.tar.bz2
gentoo-2-be37737fc804f8fd40eb59527927d2fd609270c0.zip
ver bump
Diffstat (limited to 'dev-util/strace/strace-4.5.7.ebuild')
-rw-r--r--dev-util/strace/strace-4.5.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/strace/strace-4.5.7.ebuild b/dev-util/strace/strace-4.5.7.ebuild
new file mode 100644
index 000000000000..a72f73ee23cf
--- /dev/null
+++ b/dev-util/strace/strace-4.5.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.7.ebuild,v 1.1 2004/09/22 03:15:40 vapier Exp $
+
+inherit flag-o-matic gnuconfig
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~arm ~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+
+ # Compile fails with -O3 on sparc but works on x86
+ if [ "${ARCH}" == "sparc" -o "${ARCH}" == "" ]; then
+ replace-flags -O[3-9] -O2
+ fi
+ filter-lfs-flags
+
+ use static && append-ldflags -static
+}
+
+src_install() {
+ # Can't use make install because it is stupid and
+ # doesn't make leading directories before trying to
+ # install. Thus, one would have to make /usr/bin
+ # and /usr/man/man1 (at least).
+ # So, we do it by hand.
+ doman strace.1
+ dobin strace strace-graph || die
+ dodoc ChangeLog CREDITS NEWS PORTING README* TODO
+}