summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-22 03:44:12 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-22 03:44:12 +0000
commit0114e07c9750d954ebfb93df6b3d00553b54ee8a (patch)
tree1199718999e73c9ce3167f918bdde8321f7b23ee /dev-util/strace
parentStable for HPPA (bug #209368). (diff)
downloadgentoo-2-0114e07c9750d954ebfb93df6b3d00553b54ee8a.tar.gz
gentoo-2-0114e07c9750d954ebfb93df6b3d00553b54ee8a.tar.bz2
gentoo-2-0114e07c9750d954ebfb93df6b3d00553b54ee8a.zip
Fix building on sparc with -O3 #204457.
(Portage version: 2.2_pre2)
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/ChangeLog6
-rw-r--r--dev-util/strace/files/strace-4.5.16-sparc-times.patch35
-rw-r--r--dev-util/strace/strace-4.5.16-r1.ebuild3
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 4f8972bc57c4..5706749f4783 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/strace
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.116 2008/02/05 10:39:44 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.117 2008/02/22 03:44:11 vapier Exp $
+
+ 22 Feb 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/strace-4.5.16-sparc-times.patch, strace-4.5.16-r1.ebuild:
+ Fix building on sparc with -O3 #204457.
05 Feb 2008; Markus Rothe <corsair@gentoo.org> strace-4.5.16-r1.ebuild:
Stable on ppc64
diff --git a/dev-util/strace/files/strace-4.5.16-sparc-times.patch b/dev-util/strace/files/strace-4.5.16-sparc-times.patch
new file mode 100644
index 000000000000..9d1ee76ee9cb
--- /dev/null
+++ b/dev-util/strace/files/strace-4.5.16-sparc-times.patch
@@ -0,0 +1,35 @@
+http://bugs.gentoo.org/204457
+
+------- Comment #5 From SpanKY 2008-01-06 18:08:07 0000 [reply] -------
+
+i dont have any way of actually run time testing this, but the fix is probably:
+- tprintf("st_atime=%s, ", sprinttime(statbuf.st_atime));
+- tprintf("st_mtime=%s, ", sprinttime(statbuf.st_mtime));
+- tprintf("st_ctime=%s}", sprinttime(statbuf.st_ctime));
++ tprintf("st_atime=%s, ", sprinttime(statbuf.st_atime.tv_sec));
++ tprintf("st_mtime=%s, ", sprinttime(statbuf.st_mtime.tv_sec));
++ tprintf("st_ctime=%s}", sprinttime(statbuf.st_ctime.tv_sec));
+
+sprinttime() takes a time_t which represents the time (in seconds). the time
+members of the solstatbuf are the time (in seconds) as well as nanosecond
+granularity. since sprinttime() doesnt include nanosecond granularity, we dont
+care about that part of the time.
+
+someone needs to find a sparc system running with the personality required and
+exercise this difference
+
+--- strace-4.5.16/file.c
++++ strace-4.5.16/file.c
+@@ -766,9 +766,9 @@
+ break;
+ }
+ if (!abbrev(tcp)) {
+- tprintf("st_atime=%s, ", sprinttime(statbuf.st_atime));
+- tprintf("st_mtime=%s, ", sprinttime(statbuf.st_mtime));
+- tprintf("st_ctime=%s}", sprinttime(statbuf.st_ctime));
++ tprintf("st_atime=%s, ", sprinttime(statbuf.st_atime.tv_sec));
++ tprintf("st_mtime=%s, ", sprinttime(statbuf.st_mtime.tv_sec));
++ tprintf("st_ctime=%s}", sprinttime(statbuf.st_ctime.tv_sec));
+ }
+ else
+ tprintf("...}");
diff --git a/dev-util/strace/strace-4.5.16-r1.ebuild b/dev-util/strace/strace-4.5.16-r1.ebuild
index 66a6fa7f1bcf..f6e7b5d48240 100644
--- a/dev-util/strace/strace-4.5.16-r1.ebuild
+++ b/dev-util/strace/strace-4.5.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.16-r1.ebuild,v 1.9 2008/02/05 10:39:44 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.16-r1.ebuild,v 1.10 2008/02/22 03:44:11 vapier Exp $
inherit flag-o-matic autotools
@@ -27,6 +27,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-mips-syscallent.patch
epatch "${FILESDIR}"/${P}-sh-updates.patch
epatch "${FILESDIR}"/${P}-sparc-updates.patch #162789
+ epatch "${FILESDIR}"/${P}-sparc-times.patch #204457
epatch "${FILESDIR}"/${P}-getdents-infinite-loop.patch
eautoreconf