summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-27 15:47:41 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-27 15:47:41 +0000
commit24a22f1eb9d3d91c11773ab9be0c4fb9d9a8b632 (patch)
treefcfe4fedbb889f8a255969fc851bec402b3e52ac /dev-util/strace
parent*** empty log message *** (diff)
downloadgentoo-2-24a22f1eb9d3d91c11773ab9be0c4fb9d9a8b632.tar.gz
gentoo-2-24a22f1eb9d3d91c11773ab9be0c4fb9d9a8b632.tar.bz2
gentoo-2-24a22f1eb9d3d91c11773ab9be0c4fb9d9a8b632.zip
*** empty log message ***
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/files/digest-strace-3.991
-rw-r--r--dev-util/strace/strace-3.99.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/strace/files/digest-strace-3.99 b/dev-util/strace/files/digest-strace-3.99
new file mode 100644
index 000000000000..cab6dd93e58b
--- /dev/null
+++ b/dev-util/strace/files/digest-strace-3.99
@@ -0,0 +1 @@
+MD5 c53dccb55179de2ab058443f1b446796 strace-3.99.tar.gz
diff --git a/dev-util/strace/strace-3.99.ebuild b/dev-util/strace/strace-3.99.ebuild
new file mode 100644
index 000000000000..ed452dcd3c1c
--- /dev/null
+++ b/dev-util/strace/strace-3.99.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-3.99.ebuild,v 1.1 2000/11/27 15:47:41 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A usefull diagnostic, instructional, adn debugging tool"
+SRC_URI="http://download.sourceforge.net/strace/${A}"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_unpack () {
+ unpack ${A}
+
+}
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr ${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ doman strace.1
+ dobin strace
+ dobin strace-graph
+ dodoc ChangeLog COPYRIGHT CREDITS NEWS PORTING README* TODO
+
+}
+
+
+
+