summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-08-16 05:22:46 +0000
committerMike Frysinger <vapier@gentoo.org>2014-08-16 05:22:46 +0000
commitc2db8bd4a4efe006499c44ce32c759eaca372d1d (patch)
tree11c7f08beb05302e18031e3a4740c356ed00bfe5 /dev-util/strace
parentMark s390/sh stable. (diff)
downloadgentoo-2-c2db8bd4a4efe006499c44ce32c759eaca372d1d.tar.gz
gentoo-2-c2db8bd4a4efe006499c44ce32c759eaca372d1d.tar.bz2
gentoo-2-c2db8bd4a4efe006499c44ce32c759eaca372d1d.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/ChangeLog8
-rw-r--r--dev-util/strace/strace-4.9.ebuild47
-rw-r--r--dev-util/strace/strace-9999.ebuild3
3 files changed, 56 insertions, 2 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 9cdac415e1ce..ec7d083e84e8 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/strace
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.201 2014/08/16 05:22:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.202 2014/08/16 05:22:46 vapier Exp $
+
+*strace-4.9 (16 Aug 2014)
+
+ 16 Aug 2014; Mike Frysinger <vapier@gentoo.org> +strace-4.9.ebuild,
+ strace-9999.ebuild:
+ Version bump.
16 Aug 2014; Mike Frysinger <vapier@gentoo.org> strace-4.8.ebuild:
Mark s390/sh stable.
diff --git a/dev-util/strace/strace-4.9.ebuild b/dev-util/strace/strace-4.9.ebuild
new file mode 100644
index 000000000000..172d14d9ec97
--- /dev/null
+++ b/dev-util/strace/strace-4.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.9.ebuild,v 1.1 2014/08/16 05:22:46 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://strace.git.sourceforge.net/gitroot/strace/strace"
+ inherit git-2 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="aio +perl static"
+
+# strace only uses the header from libaio to decode structs
+DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers"
+RDEPEND=""
+
+src_prepare() {
+ if epatch_user || [[ ! -e configure ]] ; then
+ # git generation
+ ./xlat/gen.sh
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ filter-lfs-flags # configure handles this sanely
+ use static && append-ldflags -static
+
+ export ac_cv_header_libaio_h=$(usex aio)
+}
+
+src_install() {
+ default
+ use perl || rm "${ED}"/usr/bin/strace-graph
+ dodoc CREDITS
+}
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index 72fa8c0ae4a3..b69abbd7b18a 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-9999.ebuild,v 1.7 2014/01/18 01:55:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-9999.ebuild,v 1.8 2014/08/16 05:22:46 vapier Exp $
EAPI="4"
@@ -29,6 +29,7 @@ RDEPEND=""
src_prepare() {
if epatch_user || [[ ! -e configure ]] ; then
# git generation
+ ./xlat/gen.sh
eautoreconf
[[ ! -e CREDITS ]] && cp CREDITS{.in,}
fi