summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-06 03:28:34 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-06 03:28:34 +0000
commitabcf2e79734470c2aaf8641567c04c794ff799e0 (patch)
treebcabb8635614615ba014f9cd89b82e857b33a116 /dev-util/w32api
parentUse unpack_makeself rather than executing the script. (diff)
downloadgentoo-2-abcf2e79734470c2aaf8641567c04c794ff799e0.tar.gz
gentoo-2-abcf2e79734470c2aaf8641567c04c794ff799e0.tar.bz2
gentoo-2-abcf2e79734470c2aaf8641567c04c794ff799e0.zip
old
Diffstat (limited to 'dev-util/w32api')
-rw-r--r--dev-util/w32api/w32api-3.11.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-util/w32api/w32api-3.11.ebuild b/dev-util/w32api/w32api-3.11.ebuild
deleted file mode 100644
index b285b6905856..000000000000
--- a/dev-util/w32api/w32api-3.11.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/w32api/w32api-3.11.ebuild,v 1.2 2008/07/02 21:47:04 vapier Exp $
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Free Win32 runtime and import library definitions"
-HOMEPAGE="http://www.mingw.org/"
-SRC_URI="mirror://sourceforge/mingw/${P}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-DEPEND=""
-
-just_headers() {
- use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration; do not emerge this directly"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.7-DESTDIR.patch
-}
-
-src_compile() {
- just_headers && return 0
-
- CHOST=${CTARGET} strip-unsupported-flags
- econf \
- --host=${CTARGET} \
- --prefix=/usr/${CTARGET}/usr \
- || die
- emake || die
-}
-
-src_install() {
- if just_headers ; then
- insinto /usr/${CTARGET}/usr/include
- doins -r include/* || die
- else
- emake install DESTDIR="${D}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- dodoc CONTRIBUTIONS ChangeLog README.w32api TODO
- fi
-}