summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2009-02-17 07:13:56 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2009-02-17 07:13:56 +0000
commit033146e6291e23dc7f51cc9f381eaff29ecba2dc (patch)
tree0bb8febb02a63c965e99a2a2788b1206cda0b77a /dev-util
parentbad use of kde eclass in EAPI=2. Used a couple of workarounds to fix bug #259... (diff)
downloadgentoo-2-033146e6291e23dc7f51cc9f381eaff29ecba2dc.tar.gz
gentoo-2-033146e6291e23dc7f51cc9f381eaff29ecba2dc.tar.bz2
gentoo-2-033146e6291e23dc7f51cc9f381eaff29ecba2dc.zip
0.14.1 bump
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/tig/ChangeLog7
-rw-r--r--dev-util/tig/tig-0.14.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-util/tig/ChangeLog b/dev-util/tig/ChangeLog
index 82ae8dcd7be9..2a8860cf025f 100644
--- a/dev-util/tig/ChangeLog
+++ b/dev-util/tig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/tig
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/tig/ChangeLog,v 1.17 2009/02/07 23:01:56 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/tig/ChangeLog,v 1.18 2009/02/17 07:13:56 gregkh Exp $
+
+*tig-0.14.1 (17 Feb 2009)
+
+ 17 Feb 2009; Greg Kroah-Hartman <gregkh@gentoo.org> +tig-0.14.1.ebuild:
+ 0.14.1 bump
*tig-0.14 (07 Feb 2009)
diff --git a/dev-util/tig/tig-0.14.1.ebuild b/dev-util/tig/tig-0.14.1.ebuild
new file mode 100644
index 000000000000..482a6840606f
--- /dev/null
+++ b/dev-util/tig/tig-0.14.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/tig/tig-0.14.1.ebuild,v 1.1 2009/02/17 07:13:56 gregkh Exp $
+
+inherit bash-completion
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ dev-util/git"
+
+src_compile() {
+ econf CFLAGS="${CFLAGS}" || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ doman tig.1 tigrc.5
+ dodoc manual.txt
+ dohtml manual.html
+ dobashcompletion contrib/tig-completion.bash
+}