summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-12-02 16:16:00 +0000
committerPacho Ramos <pacho@gentoo.org>2014-12-02 16:16:00 +0000
commit453f0eca2697c238714f3ddb63c5d302ba552d4e (patch)
tree283ff19eabaaa40a9cab0890c1daf8f68cdbf8ac /dev-util
parentBump to eapi5, use new python eclasses (diff)
downloadgentoo-2-453f0eca2697c238714f3ddb63c5d302ba552d4e.tar.gz
gentoo-2-453f0eca2697c238714f3ddb63c5d302ba552d4e.tar.bz2
gentoo-2-453f0eca2697c238714f3ddb63c5d302ba552d4e.zip
Bump to eapi5, follow latest policies for gnome2.eclass, drop using deprecated mono.eclass
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bless/ChangeLog9
-rw-r--r--dev-util/bless/bless-0.6.0-r2.ebuild (renamed from dev-util/bless/bless-0.6.0-r1.ebuild)35
2 files changed, 29 insertions, 15 deletions
diff --git a/dev-util/bless/ChangeLog b/dev-util/bless/ChangeLog
index 8f50d1a58c4a..a190a33fa4ab 100644
--- a/dev-util/bless/ChangeLog
+++ b/dev-util/bless/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/bless
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bless/ChangeLog,v 1.22 2014/07/08 11:22:29 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bless/ChangeLog,v 1.23 2014/12/02 16:16:00 pacho Exp $
+
+*bless-0.6.0-r2 (02 Dec 2014)
+
+ 02 Dec 2014; Pacho Ramos <pacho@gentoo.org> +bless-0.6.0-r2.ebuild,
+ -bless-0.6.0-r1.ebuild:
+ Bump to eapi5, follow latest policies for gnome2.eclass, drop using deprecated
+ mono.eclass
08 Jul 2014; Pacho Ramos <pacho@gentoo.org> -bless-0.5.2.ebuild:
Drop old version as it's one of the last eapi0 consumers of gnome2.eclass
diff --git a/dev-util/bless/bless-0.6.0-r1.ebuild b/dev-util/bless/bless-0.6.0-r2.ebuild
index 44c9dd729638..a56aecc77891 100644
--- a/dev-util/bless/bless-0.6.0-r1.ebuild
+++ b/dev-util/bless/bless-0.6.0-r2.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bless/bless-0.6.0-r1.ebuild,v 1.5 2012/05/04 17:51:45 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bless/bless-0.6.0-r2.ebuild,v 1.1 2014/12/02 16:16:00 pacho Exp $
-EAPI=2
+EAPI=5
+GCONF_DEBUG="no"
-inherit autotools eutils gnome2 mono
+inherit autotools eutils gnome2 mono-env
DESCRIPTION="GTK# Hex Editor"
HOMEPAGE="http://home.gna.org/bless/"
@@ -15,23 +16,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-RDEPEND=">=dev-lang/mono-1.1.14
- >=dev-dotnet/gtk-sharp-2.12
- >=dev-dotnet/glade-sharp-2.12"
+RDEPEND="
+ >=dev-lang/mono-1.1.14
+ >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/glade-sharp-2.12
+"
DEPEND="${RDEPEND}
- app-text/scrollkeeper
- >=sys-devel/gettext-0.15
- virtual/pkgconfig"
-
-DOCS="AUTHORS ChangeLog NEWS README"
+ app-text/scrollkeeper
+ >=sys-devel/gettext-0.15
+ virtual/pkgconfig
+"
# See bug 278162
# Waiting on nunit ebuild entering the tree
RESTRICT="test"
pkg_setup() {
- G2CONF="${G2CONF} --enable-unix-specific $(use_enable debug) --docdir=/usr/share/doc/${PF} --without-scrollkeeper"
-
# Stolen from enlightenment.eclass
cp $(type -p gettextize) "${T}/" || die "Could not copy gettextize"
sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize"
@@ -43,4 +43,11 @@ src_prepare() {
epatch "${FILESDIR}/${P}-pixmap.patch"
epatch "${FILESDIR}/${P}-docpath.patch"
eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-unix-specific \
+ $(use_enable debug)
}