summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-10 10:11:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-04-10 10:11:34 +0000
commit4f2ca3c79a1b30a06a3af373c91c4b0fdba95a6a (patch)
treec66fac63f58a9858fd4ebc25254021aaa6fcc168 /dev-util
parentVersion bump. (diff)
downloadgentoo-2-4f2ca3c79a1b30a06a3af373c91c4b0fdba95a6a.tar.gz
gentoo-2-4f2ca3c79a1b30a06a3af373c91c4b0fdba95a6a.tar.bz2
gentoo-2-4f2ca3c79a1b30a06a3af373c91c4b0fdba95a6a.zip
Allow parallel build of checks.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gtest/ChangeLog5
-rw-r--r--dev-util/gtest/gtest-1.5.0.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-util/gtest/ChangeLog b/dev-util/gtest/ChangeLog
index a052ffc861ef..2e27d6e352e1 100644
--- a/dev-util/gtest/ChangeLog
+++ b/dev-util/gtest/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/gtest
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtest/ChangeLog,v 1.12 2011/02/27 15:48:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtest/ChangeLog,v 1.13 2011/04/10 10:11:34 flameeyes Exp $
+
+ 10 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org> gtest-1.5.0.ebuild:
+ Allow parallel build of checks.
27 Feb 2011; Raúl Porcel <armin76@gentoo.org> gtest-1.5.0.ebuild:
Add ~alpha/~ia64/~s390/~sh/~sparc wrt #342513
diff --git a/dev-util/gtest/gtest-1.5.0.ebuild b/dev-util/gtest/gtest-1.5.0.ebuild
index 9c901769444f..82bb6168c690 100644
--- a/dev-util/gtest/gtest-1.5.0.ebuild
+++ b/dev-util/gtest/gtest-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtest/gtest-1.5.0.ebuild,v 1.10 2011/02/27 15:48:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtest/gtest-1.5.0.ebuild,v 1.11 2011/04/10 10:11:34 flameeyes Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -34,6 +34,11 @@ src_configure() {
$(use_with threads pthreads) || die
}
+src_test() {
+ # explicitly use parallel make
+ emake check || die
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"