summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-15 21:47:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-15 21:47:16 +0000
commit69c2bdbe513be076b2ea240060e828df2ae8eb03 (patch)
treef0b94bae733388abd3738731065e4720fd87a682 /dev-util
parentunmasked -r0 after alot of testing from hardened users.. now lets hope nobody... (diff)
downloadgentoo-2-69c2bdbe513be076b2ea240060e828df2ae8eb03.tar.gz
gentoo-2-69c2bdbe513be076b2ea240060e828df2ae8eb03.tar.bz2
gentoo-2-69c2bdbe513be076b2ea240060e828df2ae8eb03.zip
don't assign to P; use epatch; error messages
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/xmingw-binutils/ChangeLog8
-rw-r--r--dev-util/xmingw-binutils/xmingw-binutils-2.14.90.0.6.ebuild36
2 files changed, 23 insertions, 21 deletions
diff --git a/dev-util/xmingw-binutils/ChangeLog b/dev-util/xmingw-binutils/ChangeLog
index cce27ce2834c..e20d140328d6 100644
--- a/dev-util/xmingw-binutils/ChangeLog
+++ b/dev-util/xmingw-binutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/xmingw-binutils
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-binutils/ChangeLog,v 1.1 2003/10/02 10:15:30 cretin Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-binutils/ChangeLog,v 1.2 2004/03/15 21:47:16 mr_bones_ Exp $
+
+ 15 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ xmingw-binutils-2.14.90.0.6.ebuild:
+ don't assign to P; use epatch; error messages
* xmingw-binutils-2.14.90.0.6 (01 Oct 2003)
diff --git a/dev-util/xmingw-binutils/xmingw-binutils-2.14.90.0.6.ebuild b/dev-util/xmingw-binutils/xmingw-binutils-2.14.90.0.6.ebuild
index b6bc59befd86..556c1de1daad 100644
--- a/dev-util/xmingw-binutils/xmingw-binutils-2.14.90.0.6.ebuild
+++ b/dev-util/xmingw-binutils/xmingw-binutils-2.14.90.0.6.ebuild
@@ -1,40 +1,38 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-binutils/xmingw-binutils-2.14.90.0.6.ebuild,v 1.1 2003/10/02 10:15:30 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-binutils/xmingw-binutils-2.14.90.0.6.ebuild,v 1.2 2004/03/15 21:47:16 mr_bones_ Exp $
-DESCRIPTION="Tools necessary to build Win32 programs"
-
-HOMEPAGE="http://sources.redhat.com/binutils/"
+inherit eutils
+MY_P=${P/xmingw-/}
+S=${WORKDIR}/${MY_P}
MINGW_PATCH=binutils-2.14.90-20030807-1-src.diff.gz
-P=${P/xmingw-/}
-
-SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
+DESCRIPTION="Tools necessary to build Win32 programs"
+HOMEPAGE="http://sources.redhat.com/binutils/"
+SRC_URI="mirror://kernel/linux/devel/binutils/${MY_P}.tar.bz2
mirror://sourceforge/mingw/${MINGW_PATCH}"
-LICENSE="GPL-2 | LGPL-2"
+LICENSE="GPL-2 | LGPL-2"
SLOT="0"
-
KEYWORDS="x86"
-
IUSE=""
DEPEND=""
-S=${WORKDIR}/${P}
-
src_unpack() {
- unpack ${P}.tar.bz2
- cd ${S}; gzip -dc ${DISTDIR}/${MINGW_PATCH} | patch -p1
+ unpack ${MY_P}.tar.bz2
+ cd ${S}
+ epatch "${DISTDIR}/${MINGW_PATCH}"
}
src_compile() {
- ./configure --target=i386-mingw32msvc --prefix=/opt/xmingw || die
-
- make || die
+ ./configure \
+ --target=i386-mingw32msvc \
+ --prefix=/opt/xmingw || die "configure failed"
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
}