summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-06-05 03:04:58 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-06-05 03:04:58 +0000
commit8666e5b016da0fa49ede86ab5d383e32d810442a (patch)
tree4fafc44edcea344acd6902e5160a954dfda0b672 /dev-util
parentInitial commit. Fixes bug #217449 (diff)
downloadgentoo-2-8666e5b016da0fa49ede86ab5d383e32d810442a.tar.gz
gentoo-2-8666e5b016da0fa49ede86ab5d383e32d810442a.tar.bz2
gentoo-2-8666e5b016da0fa49ede86ab5d383e32d810442a.zip
Added latest version and fixed some QA issues; closes bug #219011
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/duma/ChangeLog11
-rw-r--r--dev-util/duma/duma-2.4.27.ebuild6
-rw-r--r--dev-util/duma/duma-2.5.13.ebuild81
-rw-r--r--dev-util/duma/duma-2.5.8.ebuild6
4 files changed, 96 insertions, 8 deletions
diff --git a/dev-util/duma/ChangeLog b/dev-util/duma/ChangeLog
index 09123b60f51b..8e0cba1fc104 100644
--- a/dev-util/duma/ChangeLog
+++ b/dev-util/duma/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/duma
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/ChangeLog,v 1.3 2007/10/10 00:35:22 nerdboy Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/ChangeLog,v 1.4 2008/06/05 03:04:58 nerdboy Exp $
+
+*duma-2.5.13 (05 Jun 2008)
+
+ 05 Jun 2008; Steve Arnold <nerdboy@gentoo.org> +duma-2.5.13.ebuild,
+ duma-2.5.8.ebuild, duma-2.4.27.ebuild:
+ Added latest version; removed patch, and simplified install function.
+ Closes bug #219011. Also fixed minor QA issues in all three versions.
*duma-2.5.8 (10 Oct 2007)
diff --git a/dev-util/duma/duma-2.4.27.ebuild b/dev-util/duma/duma-2.4.27.ebuild
index 692a1a4f131d..4a324b1087ba 100644
--- a/dev-util/duma/duma-2.4.27.ebuild
+++ b/dev-util/duma/duma-2.4.27.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.4.27.ebuild,v 1.3 2007/10/10 00:35:22 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.4.27.ebuild,v 1.4 2008/06/05 03:04:58 nerdboy Exp $
inherit eutils versionator multilib toolchain-funcs
# flag-o-matic
@@ -38,7 +38,7 @@ pkg_setup() {
}
src_unpack(){
- unpack "${A}"
+ unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-types.patch"
epatch "${FILESDIR}/${P}-make.patch"
diff --git a/dev-util/duma/duma-2.5.13.ebuild b/dev-util/duma/duma-2.5.13.ebuild
new file mode 100644
index 000000000000..3bec0d288bdc
--- /dev/null
+++ b/dev-util/duma/duma-2.5.13.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.5.13.ebuild,v 1.1 2008/06/05 03:04:58 nerdboy Exp $
+
+inherit eutils toolchain-funcs versionator
+
+MY_P="${PN}_$(replace_all_version_separators '_')"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="DUMA (Detect Unintended Memory Access) is a memory debugging library."
+HOMEPAGE="http://duma.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/duma/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ app-shells/bash"
+
+pkg_setup() {
+ #DUMA_OPTIONS="-DDUMA_LIB_NO_LEAKDETECTION"
+ DUMA_OPTIONS="-DDUMA_USE_FRAMENO"
+ if [ -n "${DUMA_OPTIONS}" ]; then
+ ewarn ""
+ elog "Custom build options are ${DUMA_OPTIONS}."
+ else
+ ewarn ""
+ elog "Custom build options are not set!"
+ fi
+ elog "See the package Makefile for for more options (also installed"
+ elog "with package docs as Makefile.duma)."
+ ewarn ""
+}
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:(prefix)/lib:(prefix)/$(get_libdir):g" Makefile
+ sed -i -e "s:share/doc/duma:share/doc/${P}:g" Makefile
+}
+
+src_compile(){
+ use amd64 && export DUMA_ALIGNMENT=16
+ # append-flags doesn't work here (stupid static makefile) and neither
+ # does distcc :(
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" CC=$(tc-getCC) \
+ || die "make failed"
+}
+
+src_test() {
+ ewarn "Control-C now if you want to disable tests..."
+ epause 5
+
+ cd "${S}"
+ use amd64 && export DUMA_ALIGNMENT=16
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" \
+ CC=$(tc-getCC) test || die "make test failed"
+
+ elog ""
+ ewarn "Check output above to verify all tests have passed. Both"
+ ewarn "static and dynamic confidence tests should say PASSED."
+ elog ""
+}
+
+src_install(){
+ # make install fails nicely here on the first file...
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGELOG TODO
+ # All the good comments on duma build options are in the Makefile
+ newdoc Makefile Makefile.duma
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins example[1-6].cpp
+ doins example_makes/ex6/Makefile
+ fi
+}
diff --git a/dev-util/duma/duma-2.5.8.ebuild b/dev-util/duma/duma-2.5.8.ebuild
index b229149e8fff..b03ec8f3bb39 100644
--- a/dev-util/duma/duma-2.5.8.ebuild
+++ b/dev-util/duma/duma-2.5.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.5.8.ebuild,v 1.1 2007/10/10 00:35:22 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.5.8.ebuild,v 1.2 2008/06/05 03:04:58 nerdboy Exp $
inherit eutils toolchain-funcs versionator
@@ -37,7 +37,7 @@ pkg_setup() {
}
src_unpack(){
- unpack "${A}"
+ unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-soname.patch"
}