summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-01-18 22:00:16 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-01-18 22:00:16 +0000
commit9938f374414d5d35deb4fb1925d7de29459bf501 (patch)
tree1f38f3ecb9de3ae6fcf2b2339f6153e033b1e134 /dev-util
parentBump mpich2-1.0.8. Fixes #221193, #221635, #242180 as well as some other cle... (diff)
downloadgentoo-2-9938f374414d5d35deb4fb1925d7de29459bf501.tar.gz
gentoo-2-9938f374414d5d35deb4fb1925d7de29459bf501.tar.bz2
gentoo-2-9938f374414d5d35deb4fb1925d7de29459bf501.zip
Version bump
(Portage version: 2.2_rc22/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eric/ChangeLog9
-rw-r--r--dev-util/eric/eric-4.2.5.ebuild83
2 files changed, 90 insertions, 2 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index e51fda2fa1fc..f0800a471998 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/eric
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.67 2008/11/21 14:22:30 yngwin Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.68 2009/01/18 22:00:16 jokey Exp $
+
+*eric-4.2.5 (18 Jan 2009)
+
+ 18 Jan 2009; <jokey@gentoo.org> +eric-4.2.5.ebuild:
+ Version bump
*eric-4.2.3 (21 Nov 2008)
diff --git a/dev-util/eric/eric-4.2.5.ebuild b/dev-util/eric/eric-4.2.5.ebuild
new file mode 100644
index 000000000000..cf7c03a51968
--- /dev/null
+++ b/dev-util/eric/eric-4.2.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.2.5.ebuild,v 1.1 2009/01/18 22:00:16 jokey Exp $
+
+NEED_PYTHON=2.4
+
+inherit python eutils
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A full featured Python IDE that is written in PyQt4 using the QScintilla editor widget"
+HOMEPAGE="http://www.die-offenbachs.de/eric/index.html"
+SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz
+ linguas_cs? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-cs-${PV}.tar.gz )
+ linguas_de? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-de-${PV}.tar.gz )
+ linguas_es? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-es-${PV}.tar.gz )
+ linguas_fr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-fr-${PV}.tar.gz )
+ linguas_ru? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-ru-${PV}.tar.gz )
+ linguas_tr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-tr-${PV}.tar.gz )"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_ru linguas_tr"
+
+DEPEND="dev-python/PyQt4
+ >=dev-python/qscintilla-python-2.2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+LANGS="cs de es fr ru tr"
+
+python_version
+
+pkg_setup() {
+ if ! built_with_use 'dev-python/qscintilla-python' 'qt4'; then
+ eerror "Please build qscintilla-python with qt4 useflag."
+ die "qscintilla-python built without qt4."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/4.1.4-paths.patch
+ epatch "${FILESDIR}"/4.2.3-no-interactive.patch
+}
+
+src_install() {
+ # Change qt dir to be located in ${D}
+ dodir /usr/share/qt4/
+ ${python} install.py \
+ -z \
+ -b "/usr/bin" \
+ -i "${D}" \
+ -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
+ -c || die "python install.py failed"
+
+ make_desktop_entry "eric4 --nosplash" \
+ eric4 \
+ "/usr/$(get_libdir)/python${PYVER}/site-packages/eric4/icons/default/eric.png" \
+ "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/eric4{,plugins}
+ elog "If you want to use eric4 with mod_python, have a look at"
+ elog "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric4/patch_modpython.py\"."
+ elog
+ elog "The following packages will give eric extended functionality."
+ elog
+ elog "dev-python/pylint"
+ elog "dev-python/pysvn (in sunrise overlay atm)"
+ elog
+ elog "This version has a new plugin interface with plugin-autofetch from"
+ elog "the App itself. You may want to check those as well"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}