summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-06-05 19:47:08 +0000
committerPeter Volkov <pva@gentoo.org>2009-06-05 19:47:08 +0000
commita8e6c5312aa12a9365910bda66043bccc5d8e7d8 (patch)
tree92394397a31bbf1b991a53a5a0aaf7be48439fbd /dev-util
parentVersion bump. (diff)
downloadgentoo-2-a8e6c5312aa12a9365910bda66043bccc5d8e7d8.tar.gz
gentoo-2-a8e6c5312aa12a9365910bda66043bccc5d8e7d8.tar.bz2
gentoo-2-a8e6c5312aa12a9365910bda66043bccc5d8e7d8.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bzrtools/ChangeLog8
-rw-r--r--dev-util/bzrtools/bzrtools-1.15.0.ebuild47
-rw-r--r--dev-util/bzrtools/files/bzrtools-1.15.0-test_fetch_ghosts.patch30
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-util/bzrtools/ChangeLog b/dev-util/bzrtools/ChangeLog
index 464f50393823..5144f8333606 100644
--- a/dev-util/bzrtools/ChangeLog
+++ b/dev-util/bzrtools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/bzrtools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzrtools/ChangeLog,v 1.57 2009/06/01 13:52:36 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzrtools/ChangeLog,v 1.58 2009/06/05 19:47:06 pva Exp $
+
+*bzrtools-1.15.0 (05 Jun 2009)
+
+ 05 Jun 2009; Peter Volkov <pva@gentoo.org> +bzrtools-1.15.0.ebuild,
+ +files/bzrtools-1.15.0-test_fetch_ghosts.patch:
+ Version bump.
01 Jun 2009; Markus Meier <maekke@gentoo.org> bzrtools-1.13.0.ebuild:
amd64 stable, bug #271130
diff --git a/dev-util/bzrtools/bzrtools-1.15.0.ebuild b/dev-util/bzrtools/bzrtools-1.15.0.ebuild
new file mode 100644
index 000000000000..edfeb2fd35fe
--- /dev/null
+++ b/dev-util/bzrtools/bzrtools-1.15.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzrtools/bzrtools-1.15.0.ebuild,v 1.1 2009/06/05 19:47:06 pva Exp $
+
+EAPI="2"
+
+NEED_PYTHON=2.4
+inherit eutils distutils versionator
+
+DESCRIPTION="bzrtools is a useful collection of utilities for bzr."
+HOMEPAGE="http://bazaar-vcs.org/BzrTools"
+SRC_URI="http://launchpad.net/bzrtools/stable/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-util/bzr-$(get_version_component_range 1-2)*"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS CREDITS NEWS NEWS.Shelf README README.Shelf TODO TODO.heads TODO.Shelf"
+
+S=${WORKDIR}/${PN}
+
+PYTHON_MODNAME=bzrlib
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-test_fetch_ghosts.patch"
+ distutils_src_prepare
+}
+
+src_test() {
+ python_version
+ einfo "Running testsuite..."
+ # put a linked copy of the bzr core into the build directory to properly
+ # test the "built" version of bzrtools
+ find "$(python_get_libdir)/site-packages/bzrlib/" \
+ -mindepth 1 -maxdepth 1 \
+ \( \( -type d -and -not -name "plugins" \) -or -name "*.py" \) \
+ -exec ln -s '{}' "${S}/build/lib/bzrlib/" \;
+ touch "${S}/build/lib/bzrlib/plugins/__init__.py"
+ "${S}/test.py" "${S}/build/lib" || die "Testsuite failed."
+ # remove the "shadow" copy so it doesn't get installed
+ rm "${S}/build/lib/bzrlib/plugins/__init__.py"
+ find "${S}/build/lib/bzrlib/" -mindepth 1 -maxdepth 1 -type l -exec rm '{}' \;
+}
diff --git a/dev-util/bzrtools/files/bzrtools-1.15.0-test_fetch_ghosts.patch b/dev-util/bzrtools/files/bzrtools-1.15.0-test_fetch_ghosts.patch
new file mode 100644
index 000000000000..88882d7b7ef5
--- /dev/null
+++ b/dev-util/bzrtools/files/bzrtools-1.15.0-test_fetch_ghosts.patch
@@ -0,0 +1,30 @@
+=== added file 'tests/test_fetch_ghosts.py'
+--- tests/test_fetch_ghosts.py 1970-01-01 00:00:00 +0000
++++ tests/test_fetch_ghosts.py 2009-06-02 11:33:28 +0000
+@@ -0,0 +1,25 @@
++from bzrlib.plugins.bzrtools.fetch_ghosts import GhostFetcher
++from bzrlib.tests import TestCaseWithTransport
++
++
++class TestFetchGhosts(TestCaseWithTransport):
++
++ def prepare_with_ghosts(self):
++ tree = self.make_branch_and_tree('.')
++ tree.commit('rev1', rev_id='rev1-id')
++ tree.set_parent_ids(['rev1-id', 'ghost-id'])
++ tree.commit('rev2')
++ return tree
++
++ def test_fetch_ghosts_failure(self):
++ tree = self.prepare_with_ghosts()
++ branch = self.make_branch('branch')
++ GhostFetcher(tree.branch, branch).run()
++ self.assertFalse(tree.branch.repository.has_revision('ghost-id'))
++
++ def test_fetch_ghosts_success(self):
++ tree = self.prepare_with_ghosts()
++ ghost_tree = self.make_branch_and_tree('ghost_tree')
++ ghost_tree.commit('ghost', rev_id='ghost-id')
++ GhostFetcher(tree.branch, ghost_tree.branch).run()
++ self.assertTrue(tree.branch.repository.has_revision('ghost-id'))
+