summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-06 15:10:31 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-06 15:10:31 +0000
commitaa762d421252fd70ee1ca1a61e56aca7df789625 (patch)
treed50e49b2c3b18a01e0014158ab3432e7dd7f8d78 /dev-util
parentAdd new "btrfs" tool (bug #312579) (diff)
downloadgentoo-2-aa762d421252fd70ee1ca1a61e56aca7df789625.tar.gz
gentoo-2-aa762d421252fd70ee1ca1a61e56aca7df789625.tar.bz2
gentoo-2-aa762d421252fd70ee1ca1a61e56aca7df789625.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eric/ChangeLog8
-rw-r--r--dev-util/eric/eric-4.4.3.ebuild89
2 files changed, 96 insertions, 1 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index d1e01a3928f7..0727a3d4ff20 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/eric
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.115 2010/03/08 19:29:10 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.116 2010/04/06 15:10:31 arfrever Exp $
+
+*eric-4.4.3 (06 Apr 2010)
+
+ 06 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +eric-4.4.3.ebuild:
+ Version bump.
08 Mar 2010; Markos Chandras <hwoarang@gentoo.org> eric-4.4.1.ebuild:
Stable on amd64 wrt bug #308201
diff --git a/dev-util/eric/eric-4.4.3.ebuild b/dev-util/eric/eric-4.4.3.ebuild
new file mode 100644
index 000000000000..9da1b560ef16
--- /dev/null
+++ b/dev-util/eric/eric-4.4.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.4.3.ebuild,v 1.1 2010/04/06 15:10:31 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python
+
+MY_PN="${PN}4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A full featured Python IDE using PyQt4 and QScintilla"
+HOMEPAGE="http://eric-ide.python-projects.org/"
+SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="kde spell"
+
+DEPEND="dev-python/PyQt4[assistant,svg,webkit,X]
+ dev-python/qscintilla-python
+ kde? ( kde-base/pykde4 )"
+RDEPEND="${DEPEND}
+ >=dev-python/chardet-2.0
+ >=dev-python/pygments-1.1
+ dev-python/coverage"
+PDEPEND="spell? ( dev-python/pyenchant )"
+# 2.4 and 2.5 are restricted to avoid conditional dependency on dev-python/simplejson.
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+LANGS="cs de es fr it ru tr zh_CN"
+for L in ${LANGS}; do
+ SRC_URI="${SRC_URI}
+ linguas_${L}? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-${L/zh_CN/zh_CN.GB2312}-${PV}.tar.gz )"
+ IUSE="${IUSE} linguas_${L}"
+done
+unset L
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/eric-4.4-no-interactive.patch"
+ epatch "${FILESDIR}/remove_coverage.patch"
+ use kde || epatch "${FILESDIR}/eric-4.4-no-pykde.patch"
+
+ # Delete internal copies of dev-python/chardet, dev-python/coverage,
+ # dev-python/pygments and dev-python/simplejson.
+ rm -fr eric/ThirdParty
+ rm -fr eric/DebugClients/Python/coverage
+ rm -fr eric/DebugClients/Python3/coverage
+}
+
+src_install() {
+ installation() {
+ "$(PYTHON)" install.py \
+ -z \
+ -b "${EPREFIX}/usr/bin" \
+ -i "${D}" \
+ -d "${EPREFIX}$(python_get_sitedir)" \
+ -c
+ }
+ python_execute_function installation
+
+ doicon eric/icons/default/eric.png
+ make_desktop_entry "eric4 --nosplash" eric4 eric "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_mod_optimize eric4{,config.py,plugins}
+
+ elog
+ elog "If you want to use Eric with mod_python, have a look at"
+ elog "\"${EROOT%/}$(python_get_sitedir -f)/eric4/patch_modpython.py\"."
+ elog
+ elog "The following packages will give Eric extended functionality:"
+ elog " dev-python/pylint"
+ elog " dev-python/pysvn"
+ elog
+ elog "This version has a plugin interface with plugin-autofetch from"
+ elog "the application itself. You may want to check those as well."
+ elog
+}
+
+pkg_postrm() {
+ python_mod_cleanup eric4{,config.py,plugins}
+}