summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-01-29 15:33:42 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-01-29 15:33:42 +0000
commitb08475667503bc0b43b1df4e07b09911e37135ce (patch)
treed308e813571945d2708e2bedb023ae37fc2a4cf4 /dev-util
parentalpha/ia64/sparc stable wrt #207634 (diff)
downloadgentoo-2-b08475667503bc0b43b1df4e07b09911e37135ce.tar.gz
gentoo-2-b08475667503bc0b43b1df4e07b09911e37135ce.tar.bz2
gentoo-2-b08475667503bc0b43b1df4e07b09911e37135ce.zip
fix depend.apache usage wrt #208033
(Portage version: 2.1.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/subversion/ChangeLog6
-rw-r--r--dev-util/subversion/subversion-1.4.5.ebuild10
-rw-r--r--dev-util/subversion/subversion-1.4.6.ebuild10
3 files changed, 15 insertions, 11 deletions
diff --git a/dev-util/subversion/ChangeLog b/dev-util/subversion/ChangeLog
index 16cc6bc91b9b..59baf5753011 100644
--- a/dev-util/subversion/ChangeLog
+++ b/dev-util/subversion/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/subversion
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.291 2008/01/28 12:23:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.292 2008/01/29 15:33:42 hollow Exp $
+
+ 29 Jan 2008; Benedikt Böhm <hollow@gentoo.org> subversion-1.4.5.ebuild,
+ subversion-1.4.6.ebuild:
+ fix depend.apache usage wrt #208033
28 Jan 2008; Raúl Porcel <armin76@gentoo.org> subversion-1.4.6.ebuild:
alpha/ia64/sparc/x86 stable wrt #207572
diff --git a/dev-util/subversion/subversion-1.4.5.ebuild b/dev-util/subversion/subversion-1.4.5.ebuild
index 5a8ed104ce59..c9ffe2d1e7b4 100644
--- a/dev-util/subversion/subversion-1.4.5.ebuild
+++ b/dev-util/subversion/subversion-1.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.4.5.ebuild,v 1.11 2008/01/27 21:10:49 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.4.5.ebuild,v 1.12 2008/01/29 15:33:42 hollow Exp $
inherit bash-completion depend.apache flag-o-matic elisp-common eutils java-pkg-opt-2 libtool multilib perl-module python
@@ -121,7 +121,7 @@ src_compile() {
econf ${myconf} \
--with-apr=/usr/bin/apr-1-config \
--with-apr-util=/usr/bin/apu-1-config \
- $(use_with apache2 apxs ${APXS2}) \
+ $(use_with apache2 apxs ${APXS}) \
$(use_with berkdb berkeley-db) \
$(use_enable debug maintainer-mode) \
$(use_enable nls) \
@@ -208,9 +208,9 @@ src_install () {
# Install apache2 module config
if use apache2 ; then
- MOD="${APACHE2_MODULESDIR/${APACHE2_BASEDIR}\//}"
- dodir "${APACHE2_MODULES_CONFDIR}"
- cat <<EOF >"${D}/${APACHE2_MODULES_CONFDIR}"/47_mod_dav_svn.conf
+ MOD="${APACHE_MODULESDIR/${APACHE_BASEDIR}\//}"
+ dodir "${APACHE_MODULES_CONFDIR}"
+ cat <<EOF >"${D}/${APACHE_MODULES_CONFDIR}"/47_mod_dav_svn.conf
<IfDefine SVN>
<IfModule !mod_dav_svn.c>
LoadModule dav_svn_module ${MOD}/mod_dav_svn.so
diff --git a/dev-util/subversion/subversion-1.4.6.ebuild b/dev-util/subversion/subversion-1.4.6.ebuild
index f7aed7311140..4466030b2165 100644
--- a/dev-util/subversion/subversion-1.4.6.ebuild
+++ b/dev-util/subversion/subversion-1.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.4.6.ebuild,v 1.7 2008/01/28 12:23:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.4.6.ebuild,v 1.8 2008/01/29 15:33:42 hollow Exp $
inherit bash-completion depend.apache flag-o-matic elisp-common eutils java-pkg-opt-2 libtool multilib perl-module python
@@ -121,7 +121,7 @@ src_compile() {
econf ${myconf} \
--with-apr=/usr/bin/apr-1-config \
--with-apr-util=/usr/bin/apu-1-config \
- $(use_with apache2 apxs ${APXS2}) \
+ $(use_with apache2 apxs ${APXS}) \
$(use_with berkdb berkeley-db) \
$(use_enable debug maintainer-mode) \
$(use_enable nls) \
@@ -208,9 +208,9 @@ src_install () {
# Install apache2 module config
if use apache2 ; then
- MOD="${APACHE2_MODULESDIR/${APACHE2_BASEDIR}\//}"
- dodir "${APACHE2_MODULES_CONFDIR}"
- cat <<EOF >"${D}/${APACHE2_MODULES_CONFDIR}"/47_mod_dav_svn.conf
+ MOD="${APACHE_MODULESDIR/${APACHE_BASEDIR}\//}"
+ dodir "${APACHE_MODULES_CONFDIR}"
+ cat <<EOF >"${D}/${APACHE_MODULES_CONFDIR}"/47_mod_dav_svn.conf
<IfDefine SVN>
<IfModule !mod_dav_svn.c>
LoadModule dav_svn_module ${MOD}/mod_dav_svn.so