summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-03-06 22:47:09 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-03-06 22:47:09 +0000
commitc1e4b0b1ed2452a1aecd0ec1d18536b470c2166e (patch)
treebea2adf6ba58046feea49bc2aa4aba78af10543f /dev-util
parentVersion bump #308025 by Stefan Behte. (diff)
downloadgentoo-2-c1e4b0b1ed2452a1aecd0ec1d18536b470c2166e.tar.gz
gentoo-2-c1e4b0b1ed2452a1aecd0ec1d18536b470c2166e.tar.bz2
gentoo-2-c1e4b0b1ed2452a1aecd0ec1d18536b470c2166e.zip
Fix bug 306569 by not loading vim plugins while calling vim in gtkdoc-fixxref
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gtk-doc/ChangeLog9
-rw-r--r--dev-util/gtk-doc/files/gtk-doc-1.13-fixxref-vim-u-NONE.patch16
-rw-r--r--dev-util/gtk-doc/gtk-doc-1.13-r2.ebuild95
3 files changed, 119 insertions, 1 deletions
diff --git a/dev-util/gtk-doc/ChangeLog b/dev-util/gtk-doc/ChangeLog
index 122a4ab4a768..1e870242f391 100644
--- a/dev-util/gtk-doc/ChangeLog
+++ b/dev-util/gtk-doc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/gtk-doc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.116 2010/02/16 20:06:54 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/ChangeLog,v 1.117 2010/03/06 22:47:06 nirbheek Exp $
+
+*gtk-doc-1.13-r2 (06 Mar 2010)
+
+ 06 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +gtk-doc-1.13-r2.ebuild, +files/gtk-doc-1.13-fixxref-vim-u-NONE.patch:
+ Fix bug 306569 by not loading vim plugins while calling vim in
+ gtkdoc-fixxref
*gtk-doc-1.13-r1 (16 Feb 2010)
diff --git a/dev-util/gtk-doc/files/gtk-doc-1.13-fixxref-vim-u-NONE.patch b/dev-util/gtk-doc/files/gtk-doc-1.13-fixxref-vim-u-NONE.patch
new file mode 100644
index 000000000000..6d608fcd9061
--- /dev/null
+++ b/dev-util/gtk-doc/files/gtk-doc-1.13-fixxref-vim-u-NONE.patch
@@ -0,0 +1,16 @@
+Call vim with -u NONE instead of -u /dev/null
+This prevents plugins from being loaded, and fixes
+http://bugs.gentoo.org/show_bug.cgi?id=306569
+
+---
+--- gtkdoc-fixxref.in
++++ gtkdoc-fixxref.in
+@@ -455,7 +455,7 @@
+ close (NEWFILE);
+
+ # format source
+- system "echo 'let html_number_lines=0|let html_use_css=1|let use_xhtml=1|syn on|e $temp_source_file|run! syntax/2html.vim|wa!|qa!' | @HIGHLIGHT@ -n -e -u /dev/null -T xterm >/dev/null";
++ system "echo 'let html_number_lines=0|let html_use_css=1|let use_xhtml=1|syn on|e $temp_source_file|run! syntax/2html.vim|wa!|qa!' | @HIGHLIGHT@ -n -e -u NONE -T xterm >/dev/null";
+
+ my $highlighted_source;
+ {
diff --git a/dev-util/gtk-doc/gtk-doc-1.13-r2.ebuild b/dev-util/gtk-doc/gtk-doc-1.13-r2.ebuild
new file mode 100644
index 000000000000..f66e0fc6fcd1
--- /dev/null
+++ b/dev-util/gtk-doc/gtk-doc-1.13-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gtk-doc/gtk-doc-1.13-r2.ebuild,v 1.1 2010/03/06 22:47:06 nirbheek Exp $
+
+EAPI="2"
+
+inherit eutils elisp-common gnome2
+
+DESCRIPTION="GTK+ Documentation Generator"
+HOMEPAGE="http://www.gtk.org/gtk-doc/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="debug doc emacs test"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-lang/perl-5.6
+ >=app-text/openjade-1.3.1
+ dev-libs/libxslt
+ >=dev-libs/libxml2-2.3.6
+ ~app-text/docbook-xml-dtd-4.3
+ app-text/docbook-xsl-stylesheets
+ ~app-text/docbook-sgml-dtd-3.0
+ >=app-text/docbook-dsssl-stylesheets-1.40
+ emacs? ( virtual/emacs )"
+
+DEPEND="${RDEPEND}
+ ~dev-util/gtk-doc-am-${PV}
+ >=dev-util/pkgconfig-0.19
+ >=app-text/scrollkeeper-0.3.14
+ >=app-text/gnome-doc-utils-0.3.2
+ test? ( app-text/scrollkeeper-dtd )"
+
+SITEFILE=61${PN}-gentoo.el
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove global Emacs keybindings.
+ epatch "${FILESDIR}/${PN}-1.8-emacs-keybindings.patch"
+
+ # gtk-doc.make puts $(DOC_MODULE)-overrides.txt in EXTRA_DIST,
+ # so this file must exist to be able to "make dist".
+ # fix bug #305191, upstream ##590625.
+ epatch "${FILESDIR}/${P}-scan-touch-module-overrides.patch"
+ # This restores a compatible behavior with previous versions of gtk-doc,
+ # which is required by many tarballs, fix bug #305191, upstream #605211
+ epatch "${FILESDIR}/${P}-fixxref-compat.patch"
+
+ # Fix bug 306569 by not loading vim plugins while calling vim in
+ # gtkdoc-fixxref for fixing vim syntax highlighting
+ epatch "${FILESDIR}/${P}-fixxref-vim-u-NONE.patch"
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ use emacs && elisp-compile tools/gtk-doc.el
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Don't install those files, they are in gtk-doc-am now
+ rm "${D}"/usr/share/aclocal/gtk-doc.m4 || die "failed to remove gtk-doc.m4"
+ rm "${D}"/usr/bin/gtkdoc-rebase || die "failed to remove gtkdoc-rebase"
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ docinto examples
+ dodoc examples/*
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} tools/gtk-doc.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "gtk-doc does no longer define global key bindings for Emacs."
+ elog "You may set your own key bindings for \"gtk-doc-insert\" and"
+ elog "\"gtk-doc-insert-section\" in your ~/.emacs file."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}