summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-07-15 22:18:02 +0000
committerMike Gilbert <floppym@gentoo.org>2015-07-15 22:18:02 +0000
commitdb13d894d5326907cce8a0d82d6e5433e801e355 (patch)
tree1e34d2d662806e484b73c2078194f5fdd785ed22 /dev-util
parentRestore for buildbot (again). (diff)
downloadgentoo-2-db13d894d5326907cce8a0d82d6e5433e801e355.tar.gz
gentoo-2-db13d894d5326907cce8a0d82d6e5433e801e355.tar.bz2
gentoo-2-db13d894d5326907cce8a0d82d6e5433e801e355.zip
Add version-pinned deps for sqlalchemy and sqlalchemy-migrate. These MUST match setup.py, or we will fail at run time.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot/ChangeLog7
-rw-r--r--dev-util/buildbot/buildbot-0.8.10.ebuild5
-rw-r--r--dev-util/buildbot/buildbot-0.8.12.ebuild5
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild7
4 files changed, 16 insertions, 8 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index e7e92475b5ef..23113bc4525a 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.173 2015/06/27 13:25:35 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.174 2015/07/15 22:18:02 floppym Exp $
+
+ 15 Jul 2015; Mike Gilbert <floppym@gentoo.org> buildbot-0.8.10.ebuild,
+ buildbot-0.8.12.ebuild, buildbot-9999.ebuild:
+ Add version-pinned deps for sqlalchemy and sqlalchemy-migrate. These MUST
+ match setup.py, or we will fail at run time.
27 Jun 2015; Mikle Kolyada <zlogene@gentoo.org> buildbot-0.8.12.ebuild:
x86 stable wrt bug #551980
diff --git a/dev-util/buildbot/buildbot-0.8.10.ebuild b/dev-util/buildbot/buildbot-0.8.10.ebuild
index 73418d292696..3445a704d100 100644
--- a/dev-util/buildbot/buildbot-0.8.10.ebuild
+++ b/dev-util/buildbot/buildbot-0.8.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.10.ebuild,v 1.6 2015/04/19 09:36:43 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.10.ebuild,v 1.7 2015/07/15 22:18:02 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
@@ -23,7 +23,8 @@ IUSE="doc examples irc mail manhole test"
RDEPEND=">=dev-python/jinja-2.1[${PYTHON_USEDEP}]
dev-python/twisted-core[${PYTHON_USEDEP}]
dev-python/twisted-web[${PYTHON_USEDEP}]
- dev-python/sqlalchemy-migrate[${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.7.10-r999[${PYTHON_USEDEP}]
+ ~dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
irc? ( dev-python/twisted-words[${PYTHON_USEDEP}] )
mail? ( dev-python/twisted-mail[${PYTHON_USEDEP}] )
manhole? ( dev-python/twisted-conch[${PYTHON_USEDEP}] )"
diff --git a/dev-util/buildbot/buildbot-0.8.12.ebuild b/dev-util/buildbot/buildbot-0.8.12.ebuild
index b66063bbbbef..3a09a2c6758a 100644
--- a/dev-util/buildbot/buildbot-0.8.12.ebuild
+++ b/dev-util/buildbot/buildbot-0.8.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.12.ebuild,v 1.4 2015/06/27 13:25:35 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.12.ebuild,v 1.5 2015/07/15 22:18:02 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
@@ -23,7 +23,8 @@ IUSE="doc examples irc mail manhole test"
RDEPEND=">=dev-python/jinja-2.1[${PYTHON_USEDEP}]
dev-python/twisted-core[${PYTHON_USEDEP}]
dev-python/twisted-web[${PYTHON_USEDEP}]
- dev-python/sqlalchemy-migrate[${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.7.10-r999[${PYTHON_USEDEP}]
+ ~dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
irc? ( dev-python/twisted-words[${PYTHON_USEDEP}] )
mail? ( dev-python/twisted-mail[${PYTHON_USEDEP}] )
manhole? ( dev-python/twisted-conch[${PYTHON_USEDEP}] )"
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index abeae4acfe9a..95ec84af815f 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-9999.ebuild,v 1.10 2014/12/18 20:48:07 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-9999.ebuild,v 1.11 2015/07/15 22:18:02 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
@@ -30,7 +30,8 @@ IUSE="doc examples irc mail manhole test"
RDEPEND=">=dev-python/jinja-2.1[${PYTHON_USEDEP}]
dev-python/twisted-core[${PYTHON_USEDEP}]
dev-python/twisted-web[${PYTHON_USEDEP}]
- dev-python/sqlalchemy-migrate[${PYTHON_USEDEP}]
+ <=dev-python/sqlalchemy-0.7.10-r999[${PYTHON_USEDEP}]
+ ~dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
irc? ( dev-python/twisted-words[${PYTHON_USEDEP}] )
mail? ( dev-python/twisted-mail[${PYTHON_USEDEP}] )
manhole? ( dev-python/twisted-conch[${PYTHON_USEDEP}] )"