summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-03-17 15:13:27 +0000
committerSebastian Pipping <sping@gentoo.org>2010-03-17 15:13:27 +0000
commit93ebfb3fabdc1a938eecf56fc4b9ccaa0e345d30 (patch)
tree11b4f2065bf8621cdfc0864734386f9d4de91530 /dev-vcs/git/files
parentPrepare move of dev-util/git to dev-vcs/git (diff)
downloadgentoo-2-93ebfb3fabdc1a938eecf56fc4b9ccaa0e345d30.tar.gz
gentoo-2-93ebfb3fabdc1a938eecf56fc4b9ccaa0e345d30.tar.bz2
gentoo-2-93ebfb3fabdc1a938eecf56fc4b9ccaa0e345d30.zip
dev-vcs/git: New package (copied from dev-util/git)
(Portage version: 2.2_rc67/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'dev-vcs/git/files')
-rw-r--r--dev-vcs/git/files/50git-gentoo.el13
-rw-r--r--dev-vcs/git/files/git-1.6.6-always-install-js.patch36
-rw-r--r--dev-vcs/git/files/git-1.7.0-always-install-js.patch36
-rw-r--r--dev-vcs/git/files/git-daemon.confd19
-rw-r--r--dev-vcs/git/files/git-daemon.initd30
-rw-r--r--dev-vcs/git/files/git-daemon.xinetd13
6 files changed, 147 insertions, 0 deletions
diff --git a/dev-vcs/git/files/50git-gentoo.el b/dev-vcs/git/files/50git-gentoo.el
new file mode 100644
index 000000000000..1646a391c53c
--- /dev/null
+++ b/dev-vcs/git/files/50git-gentoo.el
@@ -0,0 +1,13 @@
+
+;;; dev-vcs/git site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'git-status "git" "Entry point into git-status mode." t)
+;;(autoload 'git-blame-mode "git-blame"
+;; "Minor mode for incremental blame for Git." t)
+
+;; GNU Emacs >=22.2 already includes vc-git.el.
+;; Enable the following only if Emacs has no GIT support.
+(unless (fboundp 'vc-git-registered)
+ (add-to-list 'load-path "@SITELISP@/compat")
+ (add-to-list 'vc-handled-backends 'GIT))
diff --git a/dev-vcs/git/files/git-1.6.6-always-install-js.patch b/dev-vcs/git/files/git-1.6.6-always-install-js.patch
new file mode 100644
index 000000000000..f4a3825102cd
--- /dev/null
+++ b/dev-vcs/git/files/git-1.6.6-always-install-js.patch
@@ -0,0 +1,36 @@
+JS install cleanup fixes
+
+- Always install the JS for GitWeb, even if it is not being minified.
+- Also ensure the minified JS is built before instaweb as it is referenced in
+ the sed expression.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar git-1.6.6.orig/Makefile git-1.6.6/Makefile
+--- git-1.6.6.orig/Makefile 2009-12-24 00:00:22.000000000 +0000
++++ git-1.6.6/Makefile 2009-12-25 23:47:57.089719735 +0000
+@@ -1509,13 +1509,8 @@
+ chmod +x $@+ && \
+ mv $@+ $@
+
+-ifdef JSMIN
+-OTHER_PROGRAMS += gitweb/gitweb.cgi gitweb/gitweb.min.js
+-gitweb/gitweb.cgi: gitweb/gitweb.perl gitweb/gitweb.min.js
+-else
+-OTHER_PROGRAMS += gitweb/gitweb.cgi
+-gitweb/gitweb.cgi: gitweb/gitweb.perl
+-endif
++OTHER_PROGRAMS += gitweb/gitweb.cgi gitweb/$(GITWEB_JS)
++gitweb/gitweb.cgi: gitweb/gitweb.perl gitweb/$(GITWEB_JS)
+ $(QUIET_GEN)$(RM) $@ $@+ && \
+ sed -e '1s|#!.*perl|#!$(PERL_PATH_SQ)|' \
+ -e 's|++GIT_VERSION++|$(GIT_VERSION)|g' \
+@@ -1541,7 +1536,7 @@
+ chmod +x $@+ && \
+ mv $@+ $@
+
+-git-instaweb: git-instaweb.sh gitweb/gitweb.cgi gitweb/gitweb.css gitweb/gitweb.js
++git-instaweb: git-instaweb.sh gitweb/gitweb.cgi gitweb/gitweb.css gitweb/$(GITWEB_JS)
+ $(QUIET_GEN)$(RM) $@ $@+ && \
+ sed -e '1s|#!.*/sh|#!$(SHELL_PATH_SQ)|' \
+ -e 's/@@GIT_VERSION@@/$(GIT_VERSION)/g' \
diff --git a/dev-vcs/git/files/git-1.7.0-always-install-js.patch b/dev-vcs/git/files/git-1.7.0-always-install-js.patch
new file mode 100644
index 000000000000..56f455e47601
--- /dev/null
+++ b/dev-vcs/git/files/git-1.7.0-always-install-js.patch
@@ -0,0 +1,36 @@
+JS install cleanup fixes
+
+- Always install the JS for GitWeb, even if it is not being minified.
+- Also ensure the minified JS is built before instaweb as it is referenced in
+ the sed expression.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar --exclude '*.rej' --exclude '*.orig' git-1.7.0.orig/Makefile git-1.7.0/Makefile
+--- git-1.7.0.orig/Makefile 2010-02-13 00:44:43.000000000 +0000
++++ git-1.7.0/Makefile 2010-02-13 18:11:52.923807675 +0000
+@@ -1500,13 +1500,8 @@
+ gitweb:
+ $(QUIET_SUBDIR0)gitweb $(QUIET_SUBDIR1) all
+
+-ifdef JSMIN
+-OTHER_PROGRAMS += gitweb/gitweb.cgi gitweb/gitweb.min.js
+-gitweb/gitweb.cgi: gitweb/gitweb.perl gitweb/gitweb.min.js
+-else
+-OTHER_PROGRAMS += gitweb/gitweb.cgi
+-gitweb/gitweb.cgi: gitweb/gitweb.perl
+-endif
++OTHER_PROGRAMS += gitweb/gitweb.cgi gitweb/$(GITWEB_JS)
++gitweb/gitweb.cgi: gitweb/gitweb.perl gitweb/$(GITWEB_JS)
+ $(QUIET_SUBDIR0)gitweb $(QUIET_SUBDIR1) $(patsubst gitweb/%,%,$@)
+
+ ifdef JSMIN
+@@ -1515,7 +1510,7 @@
+ endif # JSMIN
+
+
+-git-instaweb: git-instaweb.sh gitweb/gitweb.cgi gitweb/gitweb.css gitweb/gitweb.js
++git-instaweb: git-instaweb.sh gitweb/gitweb.cgi gitweb/gitweb.css gitweb/$(GITWEB_JS)
+ $(QUIET_GEN)$(RM) $@ $@+ && \
+ sed -e '1s|#!.*/sh|#!$(SHELL_PATH_SQ)|' \
+ -e 's/@@GIT_VERSION@@/$(GIT_VERSION)/g' \
diff --git a/dev-vcs/git/files/git-daemon.confd b/dev-vcs/git/files/git-daemon.confd
new file mode 100644
index 000000000000..75b421680c80
--- /dev/null
+++ b/dev-vcs/git/files/git-daemon.confd
@@ -0,0 +1,19 @@
+# conf.d file for git-daemon
+#
+# Please check man 1 git-daemon for more information about the options
+# git-daemon accepts. You MUST edit this to include your repositories you wish
+# to serve.
+#
+# Some of the meaningful options are:
+# --syslog --- Enables syslog logging
+# --verbose --- Enables verbose logging
+# --export-all --- Exports all repositories
+# --port=XXXX --- Starts in port XXXX instead of 9418
+#
+GITDAEMON_OPTS="--syslog /var/git"
+
+# To run an anonymous git safely, the following user should be able to only
+# read your Git repositories. It should not able able to write to anywhere on
+# your system, esp. not the repositories.
+GIT_USER="nobody"
+GIT_GROUP="nobody"
diff --git a/dev-vcs/git/files/git-daemon.initd b/dev-vcs/git/files/git-daemon.initd
new file mode 100644
index 000000000000..c6ee19f5c034
--- /dev/null
+++ b/dev-vcs/git/files/git-daemon.initd
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/files/git-daemon.initd,v 1.1 2010/03/17 15:13:27 sping Exp $
+
+PIDFILE=/var/run/git-daemon.pid
+
+depend() {
+ need net
+ use logger
+}
+
+start() {
+ [ -e /lib/librc.so ] || BL1_COMPAT="--name git-daemon"
+ ebegin "Starting git-daemon"
+ start-stop-daemon --start --quiet --background \
+ --pidfile ${PIDFILE} ${BL1_COMPAT} \
+ --exec /usr/bin/git -- daemon \
+ --pid-file=${PIDFILE} \
+ --user=${GIT_USER} --group=${GIT_GROUP} \
+ ${GITDAEMON_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping git-daemon"
+ start-stop-daemon --stop --quiet \
+ --pidfile ${PIDFILE}
+ eend $?
+}
diff --git a/dev-vcs/git/files/git-daemon.xinetd b/dev-vcs/git/files/git-daemon.xinetd
new file mode 100644
index 000000000000..02c938d4bd6c
--- /dev/null
+++ b/dev-vcs/git/files/git-daemon.xinetd
@@ -0,0 +1,13 @@
+service git-daemon
+{
+ disable = yes
+ socket_type = stream
+ wait = no
+ user = nobody
+ type = UNLISTED
+ protocol = tcp
+ log_on_failure += USERID
+ port = 9418
+ server = /usr/bin/git
+ server_args = daemon --inetd --syslog --export-all --base-path=/var/git
+}