summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-19 16:05:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-19 16:05:25 +0000
commitd26fd5b3a3049d59793c51a235c6ce4781fb1a4c (patch)
treede871c5cce92576e48d44f6335358a11f7b6f102 /dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild
parentBackport fixes for deprecation warnings from omniORB-4.1.4-r1. (diff)
downloadgentoo-2-d26fd5b3a3049d59793c51a235c6ce4781fb1a4c.tar.gz
gentoo-2-d26fd5b3a3049d59793c51a235c6ce4781fb1a4c.tar.bz2
gentoo-2-d26fd5b3a3049d59793c51a235c6ce4781fb1a4c.zip
dev-util/gitosis renamed to dev-vcs/gitosis (bug #56967).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild')
-rw-r--r--dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild b/dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild
new file mode 100644
index 000000000000..f188879734b9
--- /dev/null
+++ b/dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis/gitosis-0.2_p20080825.ebuild,v 1.1 2010/06/19 16:05:25 arfrever Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="gitosis -- software for hosting git repositories"
+HOMEPAGE="http://eagain.net/gitweb/?p=gitosis.git;a=summary"
+# This is a snapshot taken from the upstream gitweb.
+MY_PV="20080825-73a032520493f6b4186185d4826d12edb5614135"
+MY_PN="${PN}.git"
+MY_P="${MY_PN}-${MY_PV}"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+DEPEND_GIT=">=dev-vcs/git-1.5.5.4"
+DEPEND="${DEPEND_GIT}
+ >=dev-python/setuptools-0.6_rc5"
+RDEPEND="${DEPEND}
+ !dev-util/gitosis-gentoo"
+
+S=${WORKDIR}/gitosis
+
+DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/sh /var/spool/gitosis git
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/spool/gitosis
+ fowners git:git /var/spool/gitosis
+}
+
+# We should handle more of this, but it requires the input of an SSH public key
+# from the user, and they may want to set up more configuration first.
+#pkg_config() {
+#}