summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-03-06 20:48:09 +0000
committerUlrich Müller <ulm@gentoo.org>2010-03-06 20:48:09 +0000
commitc685462bc3467cc7a01b5a34946a26b7046b5903 (patch)
tree03c48e09a79f49c05861d7e190028ab10a6374b8 /dev-vcs/svnmailer
parentBug #300352: Fix perl bindings. (diff)
downloadgentoo-2-c685462bc3467cc7a01b5a34946a26b7046b5903.tar.gz
gentoo-2-c685462bc3467cc7a01b5a34946a26b7046b5903.tar.bz2
gentoo-2-c685462bc3467cc7a01b5a34946a26b7046b5903.zip
Move package from dev-util to dev-vcs, bug 56967.
(Portage version: 2.2_rc65/cvs/Linux i686)
Diffstat (limited to 'dev-vcs/svnmailer')
-rw-r--r--dev-vcs/svnmailer/ChangeLog47
-rw-r--r--dev-vcs/svnmailer/files/svnmailer-1.0.8-python2.5.diff47
-rw-r--r--dev-vcs/svnmailer/metadata.xml9
-rw-r--r--dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild32
4 files changed, 135 insertions, 0 deletions
diff --git a/dev-vcs/svnmailer/ChangeLog b/dev-vcs/svnmailer/ChangeLog
new file mode 100644
index 000000000000..300dda60cdfa
--- /dev/null
+++ b/dev-vcs/svnmailer/ChangeLog
@@ -0,0 +1,47 @@
+# ChangeLog for dev-vcs/svnmailer
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svnmailer/ChangeLog,v 1.1 2010/03/06 20:48:08 ulm Exp $
+
+ 06 Mar 2010; Ulrich Mueller <ulm@gentoo.org> +svnmailer-1.0.8-r2.ebuild,
+ +files/svnmailer-1.0.8-python2.5.diff, +metadata.xml:
+ Move package from dev-util to dev-vcs, bug 56967.
+
+ 27 Sep 2008; Petteri Räty <betelgeuse@gentoo.org>
+ svnmailer-1.0.8-r2.ebuild:
+ Use EAPI 2 use dependencies instead of built_with_use.
+
+ 27 Sep 2008; Petteri Räty <betelgeuse@gentoo.org>
+ -svnmailer-1.0.8.ebuild, -svnmailer-1.0.8-r1.ebuild:
+ Remove old ebuilds.
+
+ 28 May 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
+ Removing Andrew Ross (aross) from metadata.xml (as per #139633). Assigning
+ to maintainer-needed.
+
+*svnmailer-1.0.8-r2 (06 Apr 2008)
+
+ 06 Apr 2008; Hanno Boeck <hanno@gentoo.org>
+ +files/svnmailer-1.0.8-python2.5.diff, +svnmailer-1.0.8-r2.ebuild:
+ Patch for Python 2.5.
+
+*svnmailer-1.0.8-r1 (26 Jan 2007)
+
+ 26 Jan 2007; Andrew Ross <aross@gentoo.org> +svnmailer-1.0.8-r1.ebuild:
+ Detect when subversion was built without USE=python, thanks to Nicolas
+ Litchinko <n.litchinko@noos.fr> in bug #163933
+
+ 26 Jan 2007; Andrew Ross <aross@gentoo.org> metadata.xml,
+ svnmailer-1.0.8.ebuild:
+ Take over maintainership from retired dev (bug #73878). Install HTML docs in
+ the correct location (bug #157575).
+
+ 30 Jun 2006; Sebastian Bergmann <sebastian@gentoo.org>
+ svnmailer-1.0.8.ebuild:
+ Mark ~amd64.
+
+*svnmailer-1.0.8 (30 Jun 2006)
+
+ 30 Jun 2006; Sebastian Bergmann <sebastian@gentoo.org> +metadata.xml,
+ +svnmailer-1.0.8.ebuild:
+ Initial ebuild, based upon work by Andre Malo <nd@apache.org>.
+
diff --git a/dev-vcs/svnmailer/files/svnmailer-1.0.8-python2.5.diff b/dev-vcs/svnmailer/files/svnmailer-1.0.8-python2.5.diff
new file mode 100644
index 000000000000..348f26f36a0a
--- /dev/null
+++ b/dev-vcs/svnmailer/files/svnmailer-1.0.8-python2.5.diff
@@ -0,0 +1,47 @@
+Index: src/lib/svnmailer/notifier/_base.py
+===================================================================
+--- src/lib/svnmailer/notifier/_base.py
++++ src/lib/svnmailer/notifier/_base.py 2007-05-01 00:54:23.000000000 +0200
+@@ -345,7 +345,6 @@
+ @return: The two encodings
+ @rtype: C{tuple} of C{str}
+ """
+- from encodings import exceptions
+
+ enc1 = enc2 = default
+ if not change.wasAdded() or change.wasCopied():
+@@ -353,7 +352,7 @@
+ enc1 = self._getContentEncoding(
+ change.getBasePath(), change.getBaseRevision()
+ )
+- except exceptions.LookupError:
++ except LookupError:
+ # fall back
+ pass
+
+@@ -364,7 +363,7 @@
+ enc2 = self._getContentEncoding(
+ change.path, change.revision
+ )
+- except exceptions.LookupError:
++ except LookupError:
+ # fall back
+ pass
+
+@@ -389,7 +388,6 @@
+ @exception encodings.exception.LookupError: The specified encoding
+ is not implemented or no encoding was specified
+ """
+- from encodings import exceptions
+
+ # first try the svn:mime-type
+ enc = self.getEncodingFromMimeType(path, revision)
+@@ -427,7 +425,7 @@
+ codecs.lookup(enc)
+ return enc
+
+- raise exceptions.LookupError("No Encoding configured")
++ raise LookupError("No Encoding configured")
+
+
+ def getEncodingFromMimeType(self, path, revision):
diff --git a/dev-vcs/svnmailer/metadata.xml b/dev-vcs/svnmailer/metadata.xml
new file mode 100644
index 000000000000..50f3f2ba6e30
--- /dev/null
+++ b/dev-vcs/svnmailer/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild b/dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild
new file mode 100644
index 000000000000..dd9cb3cec352
--- /dev/null
+++ b/dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svnmailer/svnmailer-1.0.8-r2.ebuild,v 1.1 2010/03/06 20:48:08 ulm Exp $
+
+EAPI=2
+
+inherit distutils eutils
+
+DESCRIPTION="A subversion commit notifier written in Python"
+HOMEPAGE="http://opensource.perlig.de/svnmailer/"
+SRC_URI="http://storage.perlig.de/svnmailer/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+RDEPEND="${DEPEND}
+ dev-util/subversion[python]
+ virtual/mta"
+
+DOCS="CHANGES NOTICE CREDITS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-python2.5.diff
+}
+
+src_install() {
+ distutils_src_install
+ dohtml -r docs/* || die "failed to install HTML documentation"
+}