summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 12:45:45 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 12:45:45 +0000
commit061d598e1336f605ba0f417c108ffb36481612cd (patch)
tree164bb82b7c87a1fb1cfb7c35f8bd3ff105305bbb /dev-vcs
parentImport the live ebuild. (diff)
downloadgentoo-2-061d598e1336f605ba0f417c108ffb36481612cd.tar.gz
gentoo-2-061d598e1336f605ba0f417c108ffb36481612cd.tar.bz2
gentoo-2-061d598e1336f605ba0f417c108ffb36481612cd.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-bz/ChangeLog8
-rw-r--r--dev-vcs/git-bz/git-bz-9999.ebuild49
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-vcs/git-bz/ChangeLog b/dev-vcs/git-bz/ChangeLog
index 7e76f4cd8436..f39da9bcb5a9 100644
--- a/dev-vcs/git-bz/ChangeLog
+++ b/dev-vcs/git-bz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/git-bz
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bz/ChangeLog,v 1.2 2012/04/26 06:07:54 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bz/ChangeLog,v 1.3 2012/12/15 12:45:45 mgorny Exp $
+
+*git-bz-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +git-bz-9999.ebuild:
+ Import the live ebuild.
*git-bz-0.12.04.26 (26 Apr 2012)
@@ -14,4 +19,3 @@
+metadata.xml:
Introduce an ebuild for git-bz snapshot. git-bz is a Bugzilla integration
subcommand for git.
-
diff --git a/dev-vcs/git-bz/git-bz-9999.ebuild b/dev-vcs/git-bz/git-bz-9999.ebuild
new file mode 100644
index 000000000000..1cba8fbc833c
--- /dev/null
+++ b/dev-vcs/git-bz/git-bz-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-bz/git-bz-9999.ebuild,v 1.1 2012/12/15 12:45:44 mgorny Exp $
+
+EAPI=4
+PYTHON_DEPEND=2
+
+inherit python
+
+#if LIVE
+EGIT_REPO_URI="git://git.fishsoup.net/${PN}
+ http://git.fishsoup.net/cgit/${PN}
+ https://bitbucket.org/mgorny/${PN}.git"
+inherit git-2
+#endif
+
+DESCRIPTION="Bugzilla subcommand for git"
+HOMEPAGE="http://www.fishsoup.net/software/git-bz/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+
+#if LIVE
+DEPEND="app-text/asciidoc
+ app-text/xmlto"
+
+KEYWORDS=
+SRC_URI=
+
+src_prepare() {
+ python_convert_shebangs 2 ${PN}
+ emake ${PN}.1
+}
+#endif
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc TODO
+}