summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-07-20 16:31:52 +0000
committerMike Gilbert <floppym@gentoo.org>2012-07-20 16:31:52 +0000
commit117e234b890249f4bbb01cb090f4a95fa14bc1d7 (patch)
treeab56c0b66e311fa846f7f414a6f148c3a94ca9f3 /dev-vcs
parentAdd missing slot dependencies on Qt. (diff)
downloadgentoo-2-117e234b890249f4bbb01cb090f4a95fa14bc1d7.tar.gz
gentoo-2-117e234b890249f4bbb01cb090f4a95fa14bc1d7.tar.bz2
gentoo-2-117e234b890249f4bbb01cb090f4a95fa14bc1d7.zip
Version bump. Drop nautilus use flag for bug 427174.
(Portage version: 2.2.0_alpha119/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog9
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.3.1.ebuild86
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.4.2.ebuild (renamed from dev-vcs/tortoisehg/tortoisehg-2.4.ebuild)11
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild11
4 files changed, 13 insertions, 104 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index e75df0c95d7f..ccb8cfbd2f38 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.18 2012/05/07 18:09:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.19 2012/07/20 16:31:52 floppym Exp $
+
+*tortoisehg-2.4.2 (20 Jul 2012)
+
+ 20 Jul 2012; Mike Gilbert <floppym@gentoo.org> +tortoisehg-2.4.2.ebuild,
+ -tortoisehg-2.3.1.ebuild, -tortoisehg-2.4.ebuild, tortoisehg-9999.ebuild:
+ Version bump. Drop nautilus use flag for bug 427174.
07 May 2012; Mike Gilbert <floppym@gentoo.org> tortoisehg-2.4.ebuild,
tortoisehg-9999.ebuild:
@@ -91,4 +97,3 @@
+metadata.xml:
New package, resolves bug 277383 by manny15. Thanks also to Arne
Babenhauserheide, Denilson Sá, and Alphat-PC.
-
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.3.1.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.3.1.ebuild
deleted file mode 100644
index f202bae03d3e..000000000000
--- a/dev-vcs/tortoisehg/tortoisehg-2.3.1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.3.1.ebuild,v 1.4 2012/05/03 02:25:52 floppym Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS=1
-PYTHON_DEPEND="2:2.5"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-pypy-*"
-
-inherit distutils eutils multilib
-
-if [[ ${PV} != *9999* ]]; then
- KEYWORDS="~amd64 ~x86"
- SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
-else
- inherit mercurial
- EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
- KEYWORDS=""
- SRC_URI=""
-fi
-
-DESCRIPTION="Set of graphical tools for Mercurial"
-HOMEPAGE="http://tortoisehg.bitbucket.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc nautilus"
-
-RDEPEND="dev-python/iniparse
- dev-python/pygments
- dev-python/PyQt4
- dev-python/qscintilla-python
- >=dev-vcs/mercurial-2.0
- <dev-vcs/mercurial-2.2
- nautilus? ( dev-python/nautilus-python )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.3 )"
-
-src_prepare() {
- # make the install respect multilib.
- sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
-
- if [[ ${LINGUAS+set} ]]; then
- pushd i18n/tortoisehg > /dev/null || die
- local x y keep
- for x in *.po; do
- keep=
- for y in ${LINGUAS}; do
- if [[ ${y} == ${x%.po}* ]]; then
- keep=1
- break
- fi
- done
- [[ ${keep} ]] || rm "${x}" || die
- done
- popd > /dev/null || die
- fi
-
- distutils_src_prepare
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc ; then
- emake -C doc html
- fi
-}
-
-src_install() {
- distutils_src_install
- dodoc doc/ReadMe*.txt doc/TODO
-
- if use doc ; then
- dohtml -r doc/build/html || die
- fi
-
- insinto /usr/share/icons/hicolor/scalable/apps
- newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
- domenu contrib/${PN}.desktop
-
- if ! use nautilus; then
- rm -r "${ED}usr/$(get_libdir)/nautilus" || die
- fi
-}
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.4.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.4.2.ebuild
index daa3e06c729a..2d3576e78311 100644
--- a/dev-vcs/tortoisehg/tortoisehg-2.4.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.4.ebuild,v 1.2 2012/05/07 18:09:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.4.2.ebuild,v 1.1 2012/07/20 16:31:52 floppym Exp $
EAPI=4
@@ -27,14 +27,13 @@ HOMEPAGE="http://tortoisehg.bitbucket.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="doc nautilus"
+IUSE="doc"
RDEPEND="${HG_DEPEND}
dev-python/iniparse
dev-python/pygments
dev-python/PyQt4
- dev-python/qscintilla-python
- nautilus? ( dev-python/nautilus-python )"
+ dev-python/qscintilla-python"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"
@@ -80,8 +79,4 @@ src_install() {
insinto /usr/share/icons/hicolor/scalable/apps
newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
domenu contrib/${PN}.desktop
-
- if ! use nautilus; then
- rm -r "${ED}usr/$(get_libdir)/nautilus" || die
- fi
}
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index b15fe40ee16d..2238be305612 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.8 2012/05/07 18:09:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.9 2012/07/20 16:31:52 floppym Exp $
EAPI=4
@@ -27,14 +27,13 @@ HOMEPAGE="http://tortoisehg.bitbucket.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="doc nautilus"
+IUSE="doc"
RDEPEND="${HG_DEPEND}
dev-python/iniparse
dev-python/pygments
dev-python/PyQt4
- dev-python/qscintilla-python
- nautilus? ( dev-python/nautilus-python )"
+ dev-python/qscintilla-python"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"
@@ -80,8 +79,4 @@ src_install() {
insinto /usr/share/icons/hicolor/scalable/apps
newins icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
domenu contrib/${PN}.desktop
-
- if ! use nautilus; then
- rm -r "${ED}usr/$(get_libdir)/nautilus" || die
- fi
}