summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-30 08:55:29 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-30 08:55:29 +0000
commit3f1caab66840f0216fcc4f6e2789e3741ab49d87 (patch)
treef86a7b03d7fd1a791b65d0b60846adf5166a8946 /dev-vcs
parentadded ~arm (bug 302981) (diff)
downloadgentoo-2-3f1caab66840f0216fcc4f6e2789e3741ab49d87.tar.gz
gentoo-2-3f1caab66840f0216fcc4f6e2789e3741ab49d87.tar.bz2
gentoo-2-3f1caab66840f0216fcc4f6e2789e3741ab49d87.zip
Non maintainer Version Bump
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cola/ChangeLog7
-rw-r--r--dev-vcs/cola/cola-1.4.3.1.ebuild101
2 files changed, 107 insertions, 1 deletions
diff --git a/dev-vcs/cola/ChangeLog b/dev-vcs/cola/ChangeLog
index 701f0eb90df6..0c7730e35152 100644
--- a/dev-vcs/cola/ChangeLog
+++ b/dev-vcs/cola/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/cola
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/ChangeLog,v 1.6 2011/01/25 16:30:30 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/ChangeLog,v 1.7 2011/03/30 08:55:29 jlec Exp $
+
+*cola-1.4.3.1 (30 Mar 2011)
+
+ 30 Mar 2011; Justin Lecher <jlec@gentoo.org> +cola-1.4.3.1.ebuild:
+ Non maintainer Version Bump
25 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
cola-1.4.3.ebuild:
diff --git a/dev-vcs/cola/cola-1.4.3.1.ebuild b/dev-vcs/cola/cola-1.4.3.1.ebuild
new file mode 100644
index 000000000000..84af4a12be26
--- /dev/null
+++ b/dev-vcs/cola/cola-1.4.3.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cola/cola-1.4.3.1.ebuild,v 1.1 2011/03/30 08:55:29 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit distutils eutils
+
+DESCRIPTION="A sweet, carbonated git gui known for its sugary flavour and caffeine-inspired features."
+HOMEPAGE="http://cola.tuxfamily.org/"
+SRC_URI="http://cola.tuxfamily.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/PyQt4
+ >=dev-python/pyinotify-0.7.1
+ dev-python/jsonpickle
+ >=dev-vcs/git-1.6.3"
+DEPEND="${RDEPEND}
+ doc? ( app-text/asciidoc
+ dev-python/sphinx
+ app-text/xmlto )
+ sys-devel/gettext
+ test? ( dev-python/nose )"
+
+# tests currently broken due to unfinished translation framework
+RESTRICT="test"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # don't install docs into wrong location
+ sed -i \
+ -e '/doc/d' \
+ setup.py || die "sed failed"
+
+ sed -i \
+ -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
+ cola/resources.py || die "sed failed"
+
+ # don't prefix install path with homedir
+ rm setup.cfg
+
+ epatch "${FILESDIR}/1.3.8-disable-tests.patch"
+
+ python_convert_shebangs 2 bin/git-cola share/git-cola/bin/ssh-askpass
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ cd share/doc/git-cola/
+ emake all || die "building docs failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ # remove bundled libraries
+ rm -rf "${D}"/usr/share/git-cola/lib/{jsonpickle,simplejson}
+
+ # remove wrong translation file
+ rm -rf "${D}/usr/share/locale/"
+
+ insinto /usr/share/locale
+ doins -r share/locale/*
+
+ cd share/doc/git-cola/
+ dodoc *.txt
+
+ if use doc ; then
+ dohtml -r _build/html/*
+ doman *.1
+ else
+ dohtml "${FILESDIR}/index.html"
+ fi
+}
+
+src_test() {
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
+ --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
+ || die "running nosetests failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/git-cola/lib/cola
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/git-cola/lib/cola
+}