summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-10 14:38:14 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-10 14:38:14 +0000
commit4d43d48be6cf09d5000055276e1914bcfae86fd3 (patch)
treea03cc9890390e9eed7dcb1e30704a71211a09d91 /dev-vcs
parentrevbump; conversion -> distutils-r1 wrt bug #541008 (diff)
downloadgentoo-2-4d43d48be6cf09d5000055276e1914bcfae86fd3.tar.gz
gentoo-2-4d43d48be6cf09d5000055276e1914bcfae86fd3.tar.bz2
gentoo-2-4d43d48be6cf09d5000055276e1914bcfae86fd3.zip
revbump; conversion -> distutils-r1 wrt bug #541008
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/bzr-git/ChangeLog9
-rw-r--r--dev-vcs/bzr-git/bzr-git-0.6.8-r1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-vcs/bzr-git/ChangeLog b/dev-vcs/bzr-git/ChangeLog
index 7817cf7971cd..e27fd0eaa79f 100644
--- a/dev-vcs/bzr-git/ChangeLog
+++ b/dev-vcs/bzr-git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/bzr-git
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr-git/ChangeLog,v 1.16 2013/03/25 20:39:56 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr-git/ChangeLog,v 1.17 2015/03/10 14:38:14 idella4 Exp $
+
+*bzr-git-0.6.8-r1 (10 Mar 2015)
+
+ 10 Mar 2015; Ian Delaney <idella4@gentoo.org> +bzr-git-0.6.8-r1.ebuild:
+ revbump; conversion -> distutils-r1 wrt bug #541008
25 Mar 2013; Agostino Sarubbo <ago@gentoo.org> bzr-git-0.6.8.ebuild:
Stable for x86, wrt bug #457348
diff --git a/dev-vcs/bzr-git/bzr-git-0.6.8-r1.ebuild b/dev-vcs/bzr-git/bzr-git-0.6.8-r1.ebuild
new file mode 100644
index 000000000000..b514dde52a96
--- /dev/null
+++ b/dev-vcs/bzr-git/bzr-git-0.6.8-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr-git/bzr-git-0.6.8-r1.ebuild,v 1.1 2015/03/10 14:38:14 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Support for Git branches in Bazaar"
+HOMEPAGE="http://bazaar-vcs.org/BzrForeignBranches/Git"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit bzr
+ EBZR_REPO_URI="lp:bzr-git"
+ KEYWORDS=""
+else
+ SRC_URI="http://samba.org/~jelmer/bzr/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+IUSE=""
+# Test are broken, they want API functions from Dulwich which are not
+# installed in Gentoo
+RESTRICT="test"
+
+# Check info.py for dulwich and bzr version dependency info.
+# The file should be fairly straightforward to understand.
+DEPEND=""
+RDEPEND=">=dev-python/dulwich-0.8.2[${PYTHON_USEDEP}]
+ >=dev-vcs/bzr-2.5.0[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}