summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-11 16:46:34 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-11 16:46:34 +0000
commit605fe79b24ea16266c588ce15a9a07a089a5c769 (patch)
treecd358169ad36acec9fdc815c25f1bab3b1a5d03d /dev-vcs
parentErase video_cards_citron from memory. (diff)
downloadgentoo-2-605fe79b24ea16266c588ce15a9a07a089a5c769.tar.gz
gentoo-2-605fe79b24ea16266c588ce15a9a07a089a5c769.tar.bz2
gentoo-2-605fe79b24ea16266c588ce15a9a07a089a5c769.zip
dev-vcs/git-sh: Version Bump; make use of vcs-snapshot.eclass
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-sh/ChangeLog10
-rw-r--r--dev-vcs/git-sh/git-sh-1.1.ebuild10
-rw-r--r--dev-vcs/git-sh/git-sh-1.3.ebuild32
-rw-r--r--dev-vcs/git-sh/metadata.xml8
4 files changed, 49 insertions, 11 deletions
diff --git a/dev-vcs/git-sh/ChangeLog b/dev-vcs/git-sh/ChangeLog
index 97678822ef03..b9a2d95bf5a7 100644
--- a/dev-vcs/git-sh/ChangeLog
+++ b/dev-vcs/git-sh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git-sh
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/ChangeLog,v 1.5 2011/09/13 21:22:32 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/ChangeLog,v 1.6 2013/03/11 16:46:34 jlec Exp $
+
+*git-sh-1.3 (11 Mar 2013)
+
+ 11 Mar 2013; Justin Lecher <jlec@gentoo.org> git-sh-1.1.ebuild,
+ +git-sh-1.3.ebuild, metadata.xml:
+ Version Bump; make use of vcs-snapshot.eclass
13 Sep 2011; Justin Lecher <jlec@gentoo.org> git-sh-1.1.ebuild, metadata.xml:
Taken over maintainer ship, moved to EAPI=4
diff --git a/dev-vcs/git-sh/git-sh-1.1.ebuild b/dev-vcs/git-sh/git-sh-1.1.ebuild
index 88cf43268cb8..f891a25496ee 100644
--- a/dev-vcs/git-sh/git-sh-1.1.ebuild
+++ b/dev-vcs/git-sh/git-sh-1.1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/git-sh-1.1.ebuild,v 1.2 2011/09/13 21:22:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/git-sh-1.1.ebuild,v 1.3 2013/03/11 16:46:34 jlec Exp $
EAPI=4
+inherit vcs-snapshot
+
DESCRIPTION="A customized bash environment suitable for git work"
HOMEPAGE="http://github.com/rtomayko/git-sh"
SRC_URI="http://github.com/rtomayko/${PN}/tarball/${PV} -> ${P}.tar.gz"
@@ -16,12 +18,10 @@ IUSE=""
DEPEND=""
RDEPEND="dev-vcs/git"
-S="${WORKDIR}/rtomayko-${PN}-a59681d"
-
src_prepare() {
sed \
-e 's/git-completion\.bash //' \
- -e 's:/local::' -i Makefile || die "sed failed"
+ -e 's:/local::' -i Makefile || die "sed failed"
}
pkg_postinst() {
diff --git a/dev-vcs/git-sh/git-sh-1.3.ebuild b/dev-vcs/git-sh/git-sh-1.3.ebuild
new file mode 100644
index 000000000000..c396c371b0e2
--- /dev/null
+++ b/dev-vcs/git-sh/git-sh-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-sh/git-sh-1.3.ebuild,v 1.1 2013/03/11 16:46:33 jlec Exp $
+
+EAPI=5
+
+inherit vcs-snapshot
+
+DESCRIPTION="A customized bash environment suitable for git work"
+HOMEPAGE="http://github.com/rtomayko/git-sh"
+SRC_URI="https://github.com/rtomayko/git-sh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ sed \
+ -e 's/git-completion\.bash //' \
+ -e 's:/local::' -i Makefile || die "sed failed"
+}
+
+pkg_postinst() {
+ echo
+ einfo "For bash completion in git commands emerge dev-vcs/git"
+ einfo "with bash-completion USE flag."
+ echo
+}
diff --git a/dev-vcs/git-sh/metadata.xml b/dev-vcs/git-sh/metadata.xml
index 46967553746a..b5f78d71f5d3 100644
--- a/dev-vcs/git-sh/metadata.xml
+++ b/dev-vcs/git-sh/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
- <longdescription lang="en">
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
</longdescription>
</pkgmetadata>