summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2013-08-06 19:34:55 +0000
committerChristian Faulhammer <fauli@gentoo.org>2013-08-06 19:34:55 +0000
commit7551bfc222d4bb3367187b4cf04b02a75d3925c3 (patch)
tree1b11590edf5404474a142257c61578e4d0356781 /dev-vcs
parentVersion bump (diff)
downloadgentoo-2-7551bfc222d4bb3367187b4cf04b02a75d3925c3.tar.gz
gentoo-2-7551bfc222d4bb3367187b4cf04b02a75d3925c3.tar.bz2
gentoo-2-7551bfc222d4bb3367187b4cf04b02a75d3925c3.zip
version bump
(Portage version: 2.1.12.2/cvs/Linux i686, signed Manifest commit with key 2B859DE3)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/qbzr/ChangeLog7
-rw-r--r--dev-vcs/qbzr/qbzr-0.23.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-vcs/qbzr/ChangeLog b/dev-vcs/qbzr/ChangeLog
index ca0d71cc6ee3..2eb1b550c3aa 100644
--- a/dev-vcs/qbzr/ChangeLog
+++ b/dev-vcs/qbzr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/qbzr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qbzr/ChangeLog,v 1.43 2013/08/06 19:28:49 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qbzr/ChangeLog,v 1.44 2013/08/06 19:34:55 fauli Exp $
+
+*qbzr-0.23.1 (06 Aug 2013)
+
+ 06 Aug 2013; Christian Faulhammer <fauli@gentoo.org> +qbzr-0.23.1.ebuild:
+ version bump
06 Aug 2013; Christian Faulhammer <fauli@gentoo.org> -qbzr-0.21.1.ebuild,
-qbzr-0.21.2.ebuild, -qbzr-0.22.1.ebuild:
diff --git a/dev-vcs/qbzr/qbzr-0.23.1.ebuild b/dev-vcs/qbzr/qbzr-0.23.1.ebuild
new file mode 100644
index 000000000000..a840e8e4aa2d
--- /dev/null
+++ b/dev-vcs/qbzr/qbzr-0.23.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qbzr/qbzr-0.23.1.ebuild,v 1.1 2013/08/06 19:34:55 fauli Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Qt frontend for Bazaar"
+HOMEPAGE="https://launchpad.net/qbzr"
+SRC_URI="https://edge.launchpad.net/qbzr/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+# bzr version comes from NEWS file. It's lowest version required for some
+# features to work.
+DEPEND=">=dev-vcs/bzr-2.5
+ >=dev-python/PyQt4-4.1[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+DOCS=( AUTHORS.txt NEWS.txt README.txt TODO.txt )
+PYTHON_MODNAME="bzrlib/plugins/qbzr"
+
+src_test() {
+ elog "It's impossible to run tests at this point. If you wish to run tests"
+ elog "after installation of ${PN} execute:"
+ elog " $ bzr selftest -s bzrlib.plugins.qbzr"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog
+ elog "To enable spellchecking in qcommit, please, install >=dev-python/pyenchant-1.5.0"
+ elog " # emerge -a >=dev-python/pyenchant-1.5.0"
+ elog "To enable syntax highlighting, please, install dev-python/pygments"
+ elog " # emerge -a dev-python/pygments"
+}