summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2013-10-12 14:35:35 +0000
committerMike Auty <ikelos@gentoo.org>2013-10-12 14:35:35 +0000
commit7709e037dfa983964f2b3080b83ed0d948d82c4d (patch)
tree8ca8a3c06a28eb86be780244d238226e97136477 /dev-vcs
parentClarify the wifi USE flag description and fix minor syntax issue in recent eb... (diff)
downloadgentoo-2-7709e037dfa983964f2b3080b83ed0d948d82c4d.tar.gz
gentoo-2-7709e037dfa983964f2b3080b83ed0d948d82c4d.tar.bz2
gentoo-2-7709e037dfa983964f2b3080b83ed0d948d82c4d.zip
Version bump giggle to 0.7 (bug 476902).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 6C20157A)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/giggle/ChangeLog7
-rw-r--r--dev-vcs/giggle/giggle-0.7.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-vcs/giggle/ChangeLog b/dev-vcs/giggle/ChangeLog
index f61a1571c3d9..393e97fa9f4c 100644
--- a/dev-vcs/giggle/ChangeLog
+++ b/dev-vcs/giggle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/giggle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/giggle/ChangeLog,v 1.20 2013/04/13 12:42:01 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/giggle/ChangeLog,v 1.21 2013/10/12 14:35:34 ikelos Exp $
+
+*giggle-0.7 (12 Oct 2013)
+
+ 12 Oct 2013; Mike Auty <ikelos@gentoo.org> +giggle-0.7.ebuild:
+ Version bump giggle to 0.7 (bug 476902).
13 Apr 2013; Mike Auty <ikelos@gentoo.org> -giggle-0.5.ebuild,
giggle-0.6.2.ebuild, +files/giggle-0.6.2-gtksourceview-3.8.0.patch:
diff --git a/dev-vcs/giggle/giggle-0.7.ebuild b/dev-vcs/giggle/giggle-0.7.ebuild
new file mode 100644
index 000000000000..6962cf241ca7
--- /dev/null
+++ b/dev-vcs/giggle/giggle-0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/giggle/giggle-0.7.ebuild,v 1.1 2013/10/12 14:35:35 ikelos Exp $
+
+EAPI="5"
+
+inherit gnome2 eutils
+
+DESCRIPTION="GTK+ Frontend for GIT"
+HOMEPAGE="http://live.gnome.org/giggle"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="eds"
+
+RDEPEND=">=dev-vcs/git-1.5
+ >=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.3.12:3
+ >=x11-libs/gtksourceview-3.0:3.0
+ >=x11-libs/gdk-pixbuf-2.22.0
+ gnome-base/gnome-common
+ eds? ( <gnome-extra/evolution-data-server-3.6 )
+ >=x11-libs/vte-0.28:2.90"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ app-text/yelp-tools
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35
+ >=sys-devel/autoconf-2.64
+ >=sys-devel/libtool-2"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+G2CONF="$(use_enable eds evolution-data-server)"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.6.2-gtksourceview-3.8.0.patch"
+}