summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2014-04-04 14:49:53 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2014-04-04 14:49:53 +0000
commitb0933530bb491bd8abb3ce79b9dc2d6c0caa3a17 (patch)
tree400800889c306265c9b6826765dae342ae0e6d6f /dev-vcs
parentVersion bump. (diff)
downloadgentoo-2-b0933530bb491bd8abb3ce79b9dc2d6c0caa3a17.tar.gz
gentoo-2-b0933530bb491bd8abb3ce79b9dc2d6c0caa3a17.tar.bz2
gentoo-2-b0933530bb491bd8abb3ce79b9dc2d6c0caa3a17.zip
Version bump to 2.6.0. Needed for some of my tasks. Restrict tests as they fail and upstream does not care much. bug#487216.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/bzr/ChangeLog10
-rw-r--r--dev-vcs/bzr/bzr-2.6.0.ebuild95
2 files changed, 103 insertions, 2 deletions
diff --git a/dev-vcs/bzr/ChangeLog b/dev-vcs/bzr/ChangeLog
index bf7e02295593..f343efa727cf 100644
--- a/dev-vcs/bzr/ChangeLog
+++ b/dev-vcs/bzr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/bzr
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.71 2013/11/19 18:50:51 grobian Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/ChangeLog,v 1.72 2014/04/04 14:49:53 scarabeus Exp $
+
+*bzr-2.6.0 (04 Apr 2014)
+
+ 04 Apr 2014; Tomáš Chvátal <scarabeus@gentoo.org> +bzr-2.6.0.ebuild:
+ Version bump to 2.6.0. Needed for some of my tasks. Restrict tests as they
+ fail and upstream does not care much. bug#487216.
19 Nov 2013; Fabian Groffen <grobian@gentoo.org> bzr-2.5.1-r1.ebuild:
Marked ~m68k-mint, bug #491080
diff --git a/dev-vcs/bzr/bzr-2.6.0.ebuild b/dev-vcs/bzr/bzr-2.6.0.ebuild
new file mode 100644
index 000000000000..f85ea5ba64c5
--- /dev/null
+++ b/dev-vcs/bzr/bzr-2.6.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/bzr/bzr-2.6.0.ebuild,v 1.1 2014/04/04 14:49:53 scarabeus Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="threads,ssl,xml"
+
+inherit bash-completion-r1 distutils-r1 eutils flag-o-matic versionator
+
+MY_P=${PN}-${PV}
+SERIES=$(get_version_component_range 1-2)
+
+DESCRIPTION="Bazaar is a next generation distributed version control system."
+HOMEPAGE="http://bazaar-vcs.org/"
+SRC_URI="http://launchpad.net/bzr/${SERIES}/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
+IUSE="curl doc +sftp test"
+
+RDEPEND="curl? ( dev-python/pycurl[${PYTHON_USEDEP}] )
+ sftp? ( dev-python/paramiko[${PYTHON_USEDEP}] )"
+
+DEPEND="test? (
+ ${RDEPEND}
+ >=dev-python/pyftpdlib-0.7.0[${PYTHON_USEDEP}]
+ dev-python/subunit
+ >=dev-python/testtools-0.9.5[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+# Fails tests bug#487216
+# Upstream is not exactly keen on fixing it
+RESTRICT="test"
+
+python_configure_all() {
+ # Generate the locales first to avoid a race condition.
+ esetup.py build_mo
+}
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+src_test() {
+ # Race due to conflicting ports in
+ # blackbox.test_serve.TestBzrServe.test_bzr_serve*.
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
+python_test() {
+ # Some tests expect the usual pyc compiling behaviour.
+ local -x PYTHONDONTWRITEBYTECODE
+
+ # Define tests which are known to fail below.
+ local skip_tests="("
+ # https://bugs.launchpad.net/bzr/+bug/850676
+ skip_tests+="per_transport.TransportTests.test_unicode_paths.*"
+ skip_tests+=")"
+ if [[ -n ${skip_tests} ]]; then
+ einfo "Skipping tests known to fail: ${skip_tests}"
+ fi
+
+ LC_ALL="C" "${PYTHON}" bzr --no-plugins selftest -v \
+ ${skip_tests:+-x} "${skip_tests}" || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # Fixup manpages manually; passing --install-data causes locales to be
+ # installed in /usr/share/share/locale
+ dodir /usr/share
+ mv "${ED%/}"/usr/{man,share/man} || die
+
+ dodoc doc/*.txt
+
+ if use doc; then
+ docinto developers
+ dodoc -r doc/developers/* || die
+ for doc in mini-tutorial tutorials user-{guide,reference}; do
+ docinto ${doc}
+ dodoc -r doc/en/${doc}/* || die
+ done
+ fi
+
+ dobashcomp contrib/bash/bzr || die
+}