summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-07-26 23:04:25 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-07-26 23:04:25 +0000
commitce3725a8616e2b812731380f3172cdf3e3b481b5 (patch)
tree99699459102b4983e4aec0575c1d16a09ae19fe2 /dev-vcs
parentVersion bump. (diff)
downloadgentoo-2-ce3725a8616e2b812731380f3172cdf3e3b481b5.tar.gz
gentoo-2-ce3725a8616e2b812731380f3172cdf3e3b481b5.tar.bz2
gentoo-2-ce3725a8616e2b812731380f3172cdf3e3b481b5.zip
non-maintainer commit: sync live ebuild with git-1.8.3.2.
(Portage version: 2.2.0_alpha189/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/ChangeLog5
-rw-r--r--dev-vcs/git/git-9999.ebuild83
2 files changed, 51 insertions, 37 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index e400da837baa..e618cbe00f81 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.204 2013/07/15 05:58:50 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.205 2013/07/26 23:04:25 williamh Exp $
+
+ 26 Jul 2013; William Hubbs <williamh@gentoo.org> git-9999.ebuild:
+ non-maintainer commit: sync live ebuild with git-1.8.3.2.
15 Jul 2013; Jonathan Callen <abcd@gentoo.org> git-1.8.3.2.ebuild:
Non-maintainer update: make ${PYTHON_REQUIRED_USE} conditional on USE=python;
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 5ff1e04b0965..6926dbaace7f 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.42 2013/05/18 13:48:38 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.43 2013/07/26 23:04:25 williamh Exp $
-EAPI=4
+EAPI=5
GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
-PYTHON_DEPEND="python? 2"
+PYTHON_COMPAT=( python2_{6,7} )
[[ ${PV} == *9999 ]] && SCM="git-2"
EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
-inherit toolchain-funcs eutils elisp-common perl-module bash-completion-r1 python systemd ${SCM}
+inherit toolchain-funcs eutils elisp-common perl-module bash-completion-r1 python-single-r1 systemd ${SCM}
MY_PV="${PV/_rc/.rc}"
MY_P="${PN}-${MY_PV}"
@@ -67,9 +67,10 @@ RDEPEND="${CDEPEND}
)
python? ( gtk?
(
- >=dev-python/pygtk-2.8
- dev-python/pygtksourceview:2
- ) )"
+ >=dev-python/pygtk-2.8[${PYTHON_USEDEP}]
+ dev-python/pygtksourceview:2[${PYTHON_USEDEP}]
+ )
+ ${PYTHON_DEPS} )"
# This is how info docs are created with Git:
# .txt/asciidoc --(asciidoc)---------> .xml/docbook
@@ -101,17 +102,18 @@ REQUIRED_USE="
cvs? ( perl )
subversion? ( perl )
webdav? ( curl )
+ gtk? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
"
pkg_setup() {
- if use subversion && has_version dev-vcs/subversion && built_with_use --missing false dev-vcs/subversion dso ; then
+ if use subversion && has_version "dev-vcs/subversion[dso]"; then
ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
ewarn "with USE=dso, there may be weird crashes in git-svn. You"
ewarn "have been warned."
fi
if use python ; then
- python_set_active_version 2
- python_pkg_setup
+ python-single-r1_pkg_setup
fi
}
@@ -140,6 +142,9 @@ exportmakeopts() {
myopts="${myopts} OLD_ICONV="
myopts="${myopts} NO_EXTERNAL_GREP="
+ # For svn-fe
+ extlibs="-lz -lssl ${S}/xdiff/lib.a $(usex threads -lpthread '')"
+
# can't define this to null, since the entire makefile depends on it
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
@@ -150,7 +155,8 @@ exportmakeopts() {
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
- && myopts="${myopts} USE_LIBPCRE=yes"
+ && myopts="${myopts} USE_LIBPCRE=yes" \
+ && extlibs="${extlibs} -lpcre"
use perl \
&& myopts="${myopts} INSTALLDIRS=vendor" \
|| myopts="${myopts} NO_PERL=YesPlease"
@@ -191,6 +197,7 @@ exportmakeopts() {
myopts="${myopts} NO_NSEC=YesPlease"
export MY_MAKEOPTS="${myopts}"
+ export EXTLIBS="${extlibs}"
}
src_unpack() {
@@ -211,12 +218,8 @@ src_unpack() {
}
src_prepare() {
- # bug #418431 - stated for upstream 1.7.13. Developed by Michael Schwern,
- # funded as a bounty by the Gentoo Foundation. Merged upstream in 1.8.0.
- #epatch "${FILESDIR}"/git-1.7.12-git-svn-backport.patch
-
# bug #350330 - automagic CVS when we don't want it is bad.
- epatch "${FILESDIR}"/git-1.7.12-optional-cvs.patch
+ epatch "${FILESDIR}"/git-1.8.2-optional-cvs.patch
sed -i \
-e 's:^\(CFLAGS =\).*$:\1 $(OPTCFLAGS) -Wall:' \
@@ -225,7 +228,7 @@ src_prepare() {
-e 's:^\(AR = \).*$:\1$(OPTAR):' \
-e "s:\(PYTHON_PATH = \)\(.*\)$:\1${EPREFIX}\2:" \
-e "s:\(PERL_PATH = \)\(.*\)$:\1${EPREFIX}\2:" \
- Makefile || die "sed failed"
+ Makefile contrib/svn-fe/Makefile || die "sed failed"
# Never install the private copy of Error.pm (bug #296310)
sed -i \
@@ -247,7 +250,7 @@ git_emake() {
# bug #326625: PERL_PATH, PERL_MM_OPT
# bug #320647: PYTHON_PATH
PYTHON_PATH=""
- use python && PYTHON_PATH="$(PYTHON -a)"
+ use python && PYTHON_PATH="$(python_get_PYTHON)"
emake ${MY_MAKEOPTS} \
DESTDIR="${D}" \
OPTCFLAGS="${CFLAGS}" \
@@ -260,6 +263,7 @@ git_emake() {
PYTHON_PATH="${PYTHON_PATH}" \
PERL_MM_OPT="" \
GIT_TEST_OPTS="--no-color" \
+ V=1 \
"$@"
# This is the fix for bug #326625, but it also causes breakage, see bug
# #352693.
@@ -278,8 +282,7 @@ src_compile() {
git_emake || die "emake failed"
if use emacs ; then
- elisp-compile contrib/emacs/git{,-blame}.el \
- || die "emacs modules failed"
+ elisp-compile contrib/emacs/git{,-blame}.el
fi
if use perl && use cgi ; then
@@ -310,7 +313,7 @@ src_compile() {
if use subversion ; then
cd "${S}"/contrib/svn-fe
- git_emake || die "emake svn-fe failed"
+ git_emake EXTLIBS="${EXTLIBS}" || die "emake svn-fe failed"
if use doc ; then
git_emake svn-fe.{1,html} || die "emake svn-fe.1 svn-fe.html failed"
fi
@@ -356,18 +359,17 @@ src_install() {
newbashcomp contrib/completion/git-prompt.sh ${PN}-prompt
if use emacs ; then
- elisp-install ${PN} contrib/emacs/git.{el,elc} || die
- elisp-install ${PN} contrib/emacs/git-blame.{el,elc} || die
- #elisp-install ${PN}/compat contrib/emacs/vc-git.{el,elc} || die
+ elisp-install ${PN} contrib/emacs/git.{el,elc}
+ elisp-install ${PN} contrib/emacs/git-blame.{el,elc}
+ #elisp-install ${PN}/compat contrib/emacs/vc-git.{el,elc}
# don't add automatically to the load-path, so the sitefile
# can do a conditional loading
touch "${ED}${SITELISP}/${PN}/compat/.nosearch"
- elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
if use python && use gtk ; then
- dobin "${S}"/contrib/gitview/gitview
- python_convert_shebangs ${PYTHON_ABI} "${ED}"/usr/bin/gitview
+ python_doscript "${S}"/contrib/gitview/gitview
dodoc "${S}"/contrib/gitview/gitview.txt
fi
@@ -411,6 +413,12 @@ src_install() {
cd "${S}"
fi
+ # remote-helpers
+ if use python ; then
+ python_doscript "${S}"/contrib/remote-helpers/git-remote-{bzr,hg}
+ python_optimize
+ fi
+
dodir /usr/share/${PN}/contrib
# The following are excluded:
# completion - installed above
@@ -468,10 +476,12 @@ src_install() {
newins "${FILESDIR}"/git-daemon.xinetd git-daemon
fi
- newinitd "${FILESDIR}"/git-daemon.initd git-daemon
- newconfd "${FILESDIR}"/git-daemon.confd git-daemon
- systemd_newunit "${FILESDIR}/git-daemon_at.service" "git-daemon@.service"
- systemd_dounit "${FILESDIR}/git-daemon.socket"
+ if use !prefix ; then
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+ systemd_newunit "${FILESDIR}/git-daemon_at.service" "git-daemon@.service"
+ systemd_dounit "${FILESDIR}/git-daemon.socket"
+ fi
fixlocalpod
}
@@ -485,9 +495,12 @@ src_test() {
t9601-cvsimport-vendor-branch.sh \
t9602-cvsimport-branches-tags.sh \
t9603-cvsimport-patchsets.sh"
- local tests_perl="t5502-quickfetch.sh \
+ local tests_perl="t3701-add-interactive.sh \
+ t5502-quickfetch.sh \
t5512-ls-remote.sh \
- t5520-pull.sh"
+ t5520-pull.sh \
+ t7106-reset-unborn-branch.sh \
+ t7501-commit.sh"
# Bug #225601 - t0004 is not suitable for root perm
# Bug #219839 - t1004 is not suitable for root perm
# t0001-init.sh - check for init notices EPERM* fails
@@ -521,7 +534,7 @@ src_test() {
has_version dev-vcs/cvs && \
let cvs=$cvs+1
[[ $cvs -gt 1 ]] && \
- built_with_use dev-vcs/cvs server && \
+ has_version "dev-vcs/cvs[server]" && \
let cvs=$cvs+1
if [[ $cvs -lt 3 ]]; then
einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
@@ -579,7 +592,6 @@ showpkgdeps() {
pkg_postinst() {
use emacs && elisp-site-regen
- use python && python_mod_optimize git_remote_helpers
einfo "Please read /usr/share/bash-completion/git for Git bash command completion"
einfo "Please read /usr/share/bash-completion/git-prompt for Git bash prompt"
einfo "Note that the prompt bash code is now in the seperate script"
@@ -593,5 +605,4 @@ pkg_postinst() {
pkg_postrm() {
use emacs && elisp-site-regen
- use python && python_mod_cleanup git_remote_helpers
}