summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-04 01:38:10 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-04 01:38:10 +0000
commitadcdf6ed49186c726bac223a3fbe2fad7df16cba (patch)
treea873fc7dedc40f6b6f33af0c346b8d00e5809840 /eclass/distutils.eclass
parent~x86 -> x86 and added ~ppc (diff)
downloadgentoo-2-adcdf6ed49186c726bac223a3fbe2fad7df16cba.tar.gz
gentoo-2-adcdf6ed49186c726bac223a3fbe2fad7df16cba.tar.bz2
gentoo-2-adcdf6ed49186c726bac223a3fbe2fad7df16cba.zip
allow src_install and src_compile functions to have additional parameters
Diffstat (limited to 'eclass/distutils.eclass')
-rw-r--r--eclass/distutils.eclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/eclass/distutils.eclass b/eclass/distutils.eclass
index 6b6bd94e6ba7..378a15593942 100644
--- a/eclass/distutils.eclass
+++ b/eclass/distutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.9 2003/03/06 05:47:32 kutsuya Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.10 2003/04/04 01:38:10 liquidx Exp $
#
# Author: Jon Nelson <jnelson@gentoo.org>
#
@@ -24,11 +24,11 @@ else
fi
distutils_src_compile() {
- ${python} setup.py build || die "compilation failed"
+ ${python} setup.py build ${@} || die "compilation failed"
}
distutils_src_install() {
- ${python} setup.py install --root=${D} || die
+ ${python} setup.py install --root=${D} ${@} || die
dodoc CHANGELOG COPYRIGHT KNOWN_BUGS MAINTAINERS
dodoc CONTRIBUTORS LICENSE COPYING*
dodoc Change* MANIFEST* README* ${mydoc}