summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-04-07 17:46:23 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-04-07 17:46:23 +0000
commit288c4540588788499b211675d37b1dd63e18757c (patch)
treed46cb9fd3968882df301c663edacbb464ba44712 /eclass/kde4-meta.eclass
parentAdd missing ChangeLog. (diff)
downloadgentoo-2-288c4540588788499b211675d37b1dd63e18757c.tar.gz
gentoo-2-288c4540588788499b211675d37b1dd63e18757c.tar.bz2
gentoo-2-288c4540588788499b211675d37b1dd63e18757c.zip
Guard against multiple inheritance. Make KMCOMPILEONLY sed case-insensitive to avoid file collisions in the future.
Diffstat (limited to 'eclass/kde4-meta.eclass')
-rw-r--r--eclass/kde4-meta.eclass11
1 files changed, 8 insertions, 3 deletions
diff --git a/eclass/kde4-meta.eclass b/eclass/kde4-meta.eclass
index 69cb76ad9c72..3cd949f4ce88 100644
--- a/eclass/kde4-meta.eclass
+++ b/eclass/kde4-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.69 2013/02/07 03:38:33 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.70 2013/04/07 17:46:23 kensington Exp $
#
# @ECLASS: kde4-meta.eclass
# @MAINTAINER:
@@ -12,6 +12,9 @@
# You must define KMNAME to use this eclass, and do so before inheriting it. All other variables are optional.
# Do not include the same item in more than one of KMMODULE, KMMEXTRA, KMCOMPILEONLY, KMEXTRACTONLY.
+if [[ ${___ECLASS_ONCE_KDE4_META} != "recur -_+^+_- spank" ]] ; then
+___ECLASS_ONCE_KDE4_META="recur -_+^+_- spank"
+
[[ -z ${KMNAME} ]] && die "kde4-meta.eclass inherited but KMNAME not defined - broken ebuild"
inherit kde4-base versionator
@@ -482,8 +485,8 @@ kde4-meta_change_cmakelists() {
find "${S}"/${i} -name CMakeLists.txt -print0 | \
xargs -0 sed -i \
-e 's/^#DONOTCOMPILE //g' \
- -e '/install(.*)/{s/^/#DONOTINSTALL /;}' \
- -e '/^install(/,/)/{s/^/#DONOTINSTALL /;}' \
+ -e '/install(.*)/I{s/^/#DONOTINSTALL /;}' \
+ -e '/^install(/,/)/I{s/^/#DONOTINSTALL /;}' \
-e '/kde4_install_icons(.*)/{s/^/#DONOTINSTALL /;}' || \
die "${LINENO}: sed died in the KMCOMPILEONLY section while processing ${i}"
_change_cmakelists_parent_dirs ${i}
@@ -682,3 +685,5 @@ kde4-meta_pkg_postrm() {
kde4-base_pkg_postrm
}
+
+fi