summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-04-03 11:16:52 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-04-03 11:16:52 +0000
commit74cde83f58d4c1861cba0f3ea24c96a5d1740d91 (patch)
tree6aed21d5c246ecd5df3b6ee0da6d5ffff24a1823 /eclass/perl-module.eclass
parentversion bump (diff)
downloadgentoo-2-74cde83f58d4c1861cba0f3ea24c96a5d1740d91.tar.gz
gentoo-2-74cde83f58d4c1861cba0f3ea24c96a5d1740d91.tar.bz2
gentoo-2-74cde83f58d4c1861cba0f3ea24c96a5d1740d91.zip
Corrected checks for Makefile.PL and Build.PL, closes bug 128487
Diffstat (limited to 'eclass/perl-module.eclass')
-rw-r--r--eclass/perl-module.eclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/eclass/perl-module.eclass b/eclass/perl-module.eclass
index f85a3584a962..07e86500a0b8 100644
--- a/eclass/perl-module.eclass
+++ b/eclass/perl-module.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/perl-module.eclass,v 1.85 2006/04/01 15:58:29 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/perl-module.eclass,v 1.86 2006/04/03 11:16:52 mcummings Exp $
#
# Author: Seemant Kulleen <seemant@gentoo.org>
# Maintained by the Perl herd <perl@gentoo.org>
@@ -95,12 +95,12 @@ perl-module_src_prep() {
SRC_PREP="yes"
- if [ -f ${S}/Makefile.PL ]; then
+ if [ -f Makefile.PL ]; then
einfo "Using ExtUtils::MakeMaker"
#perl Makefile.PL ${myconf} \
perl Makefile.PL ${myconf} INSTALLMAN3DIR='none'\
PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}
- elif [ -f ${S}/Build.PL ] && [ "${USE_BUILDER}" == "yes" ]; then
+ elif [ -f Build.PL ] && [ "${USE_BUILDER}" == "yes" ]; then
einfo "Using Module::Build"
if [ -z ${BUILDER_VER} ]; then
eerror
@@ -111,7 +111,7 @@ perl-module_src_prep() {
eerror
die
else
- perl ${S}/Build.PL installdirs=vendor destdir=${D} libdoc=
+ perl Build.PL installdirs=vendor destdir=${D} libdoc=
fi
else
einfo "No Make or Build file detect..."