summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2008-01-26 01:13:05 +0000
committerMike Auty <ikelos@gentoo.org>2008-01-26 01:13:05 +0000
commit17d582eabdf773558a7dd9e0a339d2a3666b7fab (patch)
tree589d830302bc23a1d89700d8b2de4078e56f1f08 /eclass
parentrun autotools in unpack phase, bug #207458 (diff)
downloadgentoo-2-17d582eabdf773558a7dd9e0a339d2a3666b7fab.tar.gz
gentoo-2-17d582eabdf773558a7dd9e0a339d2a3666b7fab.tar.bz2
gentoo-2-17d582eabdf773558a7dd9e0a339d2a3666b7fab.zip
Allow vmware-module patch application to be determined based on the the basecode in use.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/vmware-mod.eclass13
-rw-r--r--eclass/vmware.eclass4
2 files changed, 11 insertions, 6 deletions
diff --git a/eclass/vmware-mod.eclass b/eclass/vmware-mod.eclass
index 58f319dfe2fb..0dbf8f9a4069 100644
--- a/eclass/vmware-mod.eclass
+++ b/eclass/vmware-mod.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/vmware-mod.eclass,v 1.15 2007/09/20 17:07:37 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/vmware-mod.eclass,v 1.16 2008/01/26 01:13:05 ikelos Exp $
# Ensure vmware comes before linux-mod since we want linux-mod's pkg_preinst and
@@ -76,9 +76,11 @@ vmware-mod_src_unpack() {
cd "${S}"/${mod}-only
# Ensure it's not used
# rm getversion.pl
- EPATCH_SUFFIX="patch"
- epatch "${FILESDIR}"/patches
- [[ -d "${FILESDIR}"/patches/${mod} ]] && epatch "${FILESDIR}"/patches/${mod}
+ if [[ "${VMWARE_MOD_DIR}" = "${ANY_ANY}" ]] ; then
+ EPATCH_SUFFIX="patch"
+ epatch "${FILESDIR}"/patches
+ [[ -d "${FILESDIR}"/patches/${mod} ]] && epatch "${FILESDIR}"/patches/${mod}
+ fi
convert_to_m "${S}"/${mod}-only/Makefile
done
}
@@ -112,3 +114,6 @@ vmware-mod_src_install() {
# 'VME_V55' = .13
# 'VME_S1B1' = .14
# 'VME_S1??' = .15
+# 'VME_V6' = .16
+# 'VME_V6' = .17 (6.0.2)
+# 'VME_S2B1' = .18
diff --git a/eclass/vmware.eclass b/eclass/vmware.eclass
index a81be6f12f95..998693a34d8b 100644
--- a/eclass/vmware.eclass
+++ b/eclass/vmware.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/vmware.eclass,v 1.29 2007/11/25 12:12:14 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/vmware.eclass,v 1.30 2008/01/26 01:13:05 ikelos Exp $
# This eclass is for all vmware-* ebuilds in the tree and should contain all
# of the common components across the multiple packages.
@@ -13,7 +13,7 @@ EXPORT_FUNCTIONS pkg_preinst pkg_postinst pkg_setup src_install src_unpack pkg_p
DEPEND="x11-misc/shared-mime-info"
-export ANY_ANY="vmware-any-any-update114"
+export ANY_ANY="vmware-any-any-update115"
#export TOOLS_ANY="vmware-tools-any-update1"
export VMWARE_GROUP=${VMWARE_GROUP:-vmware}
export VMWARE_INSTALL_DIR=/opt/${PN//-//}