summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-25 21:13:52 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-25 21:13:52 +0000
commit4cb3c39ca48b0b4b43bf2c87d6d8c2817a66489f (patch)
tree3c7ce4cd4e5c95a10df4652b39f91ca2ebd23c60 /eclass
parentNamespace, clean up and describe _disable_ez_setup. (diff)
downloadgentoo-2-4cb3c39ca48b0b4b43bf2c87d6d8c2817a66489f.tar.gz
gentoo-2-4cb3c39ca48b0b4b43bf2c87d6d8c2817a66489f.tar.bz2
gentoo-2-4cb3c39ca48b0b4b43bf2c87d6d8c2817a66489f.zip
Copy bundled egg-info files for reuse in python_compile(). This solves issues that caused some of the files not to be installed in broken packages.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog6
-rw-r--r--eclass/distutils-r1.eclass15
2 files changed, 19 insertions, 2 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 46a908857a12..3c9c377561ca 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for eclass directory
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.934 2013/08/25 21:12:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.935 2013/08/25 21:13:52 mgorny Exp $
+
+ 25 Aug 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Copy bundled egg-info files for reuse in python_compile(). This solves issues
+ that caused some of the files not to be installed in broken packages.
25 Aug 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
Namespace, clean up and describe _disable_ez_setup.
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 273b51d35260..f6d507726d0d 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.75 2013/08/25 21:12:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.76 2013/08/25 21:13:52 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -323,6 +323,17 @@ _distutils-r1_disable_ez_setup() {
fi
}
+# @FUNCTION: _distutils-r1_copy_egg_info
+# @DESCRIPTION:
+# Copy egg-info files to the ${BUILD_DIR} (that's going to become
+# egg-base in esetup.py). This way, we respect whatever's in upstream
+# egg-info.
+_distutils-r1_copy_egg_info() {
+ mkdir -p "${BUILD_DIR}" || die
+ # stupid freebsd can't do 'cp -t ${BUILD_DIR} {} +'
+ find -name '*.egg-info' -type d -exec cp -pr {} "${BUILD_DIR}"/ ';' || die
+}
+
# @FUNCTION: distutils-r1_python_prepare_all
# @DESCRIPTION:
# The default python_prepare_all(). It applies the patches from PATCHES
@@ -383,6 +394,8 @@ distutils-r1_python_configure() {
distutils-r1_python_compile() {
debug-print-function ${FUNCNAME} "${@}"
+ _distutils-r1_copy_egg_info
+
esetup.py "${@}"
}