summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-11-16 06:33:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-11-16 06:33:01 +0000
commit7b8bd77390d1995a76c5c88c61f41ca2007ca930 (patch)
tree39e2c27de39370bdae51dafbb26304a44c4c5415 /games-action/0verkill/0verkill-0.16-r3.ebuild
parentBumping to fix doc install bug (diff)
downloadgentoo-2-7b8bd77390d1995a76c5c88c61f41ca2007ca930.tar.gz
gentoo-2-7b8bd77390d1995a76c5c88c61f41ca2007ca930.tar.bz2
gentoo-2-7b8bd77390d1995a76c5c88c61f41ca2007ca930.zip
add bounds patch from Ewgenij Starostin (bug #197556); QA fixes; patch name standardizing
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-action/0verkill/0verkill-0.16-r3.ebuild')
-rw-r--r--games-action/0verkill/0verkill-0.16-r3.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/games-action/0verkill/0verkill-0.16-r3.ebuild b/games-action/0verkill/0verkill-0.16-r3.ebuild
index 870fd36065b5..e01ef08c8996 100644
--- a/games-action/0verkill/0verkill-0.16-r3.ebuild
+++ b/games-action/0verkill/0verkill-0.16-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/0verkill-0.16-r3.ebuild,v 1.3 2007/08/08 22:02:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/0verkill/0verkill-0.16-r3.ebuild,v 1.4 2007/11/16 06:33:01 mr_bones_ Exp $
-inherit eutils games
+inherit autotools eutils games
DESCRIPTION="a bloody 2D action deathmatch-like game in ASCII-ART"
HOMEPAGE="http://artax.karlin.mff.cuni.cz/~brain/0verkill/"
@@ -18,16 +18,22 @@ DEPEND="X? ( x11-libs/libXpm )"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PV}-docs.patch
- epatch "${FILESDIR}"/${PV}-home-overflow.patch
- epatch "${FILESDIR}"/${PV}-gentoo-paths.patch
- epatch "${FILESDIR}"/${P}-underflow-check.patch #136222
+ epatch \
+ "${FILESDIR}"/${P}-docs.patch \
+ "${FILESDIR}"/${P}-home-overflow.patch \
+ "${FILESDIR}"/${P}-segv.patch \
+ "${FILESDIR}"/${P}-gentoo-paths.patch \
+ "${FILESDIR}"/${P}-underflow-check.patch #136222
sed -i \
-e "s:data/:${GAMES_DATADIR}/${PN}/data/:" cfg.h \
|| die "sed failed"
sed -i \
-e "s:@CFLAGS@ -O3 :@CFLAGS@ :" Makefile.in \
|| die "sed failed"
+ sed -i \
+ -e "/gettimeofday/s/getopt/getopt calloc/" configure.in \
+ || die "sed failed"
+ eautoreconf
}
src_compile() {