summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-07-04 04:39:45 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-07-04 04:39:45 +0000
commit9df016ecda37766f785d08d2dbfc67cc47829293 (patch)
tree1bcf516e0a0793e0495a4da5a96d6c78bcc85de0 /games-action/bzflag
parentVersion bump. (diff)
downloadgentoo-2-9df016ecda37766f785d08d2dbfc67cc47829293.tar.gz
gentoo-2-9df016ecda37766f785d08d2dbfc67cc47829293.tar.bz2
gentoo-2-9df016ecda37766f785d08d2dbfc67cc47829293.zip
Version bump to 2.4.0
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'games-action/bzflag')
-rw-r--r--games-action/bzflag/ChangeLog9
-rw-r--r--games-action/bzflag/bzflag-2.4.0.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/games-action/bzflag/ChangeLog b/games-action/bzflag/ChangeLog
index ce965bbd134e..30eef68bd33e 100644
--- a/games-action/bzflag/ChangeLog
+++ b/games-action/bzflag/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/bzflag
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.51 2010/08/13 12:18:04 josejx Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.52 2011/07/04 04:39:45 tupone Exp $
+
+*bzflag-2.4.0 (04 Jul 2011)
+
+ 04 Jul 2011; Tupone Alfredo <tupone@gentoo.org> +bzflag-2.4.0.ebuild:
+ Version bump to 2.4.0
13 Aug 2010; Joseph Jezak <josejx@gentoo.org> bzflag-2.0.16.ebuild:
Marked ppc stable for bug #318881.
diff --git a/games-action/bzflag/bzflag-2.4.0.ebuild b/games-action/bzflag/bzflag-2.4.0.ebuild
new file mode 100644
index 000000000000..7745af0b1217
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.4.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.4.0.ebuild,v 1.1 2011/07/04 04:39:45 tupone Exp $
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="http://www.bzflag.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated sdl"
+
+UIDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[audio,joystick,video]
+ media-libs/glew
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm"
+
+DEPEND=">=net-misc/curl-7.15.0
+ sys-libs/ncurses
+ net-dns/c-ares
+ sdl? ( ${UIDEPEND} )
+ !sdl? ( !dedicated? ( ${UIDEPEND} ) )"
+
+src_configure() {
+ local myconf
+
+ if use dedicated && ! use sdl ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf="--disable-client --without-SDL"
+ fi
+ egamesconf \
+ --disable-ccachetest \
+ --disable-dependency-tracking \
+ --without-regex \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS TODO ChangeLog BUGS PORTING DEVINFO NEWS README* RELNOTES
+
+ if use sdl || ! use dedicated ; then
+ newicon "data/bzflag-48x48.png" ${PN}.png
+ make_desktop_entry ${PN} "BZFlag"
+ fi
+
+ prepgamesdirs
+}